非常可乐 (BFS)

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

思路:BFS六种操作,注意当s为偶数时,可能无法平分,程序遍历到最后没找到合法答案时应该输出  NO  !!!   即在BFS的最后return 一个找不到的标志! 

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int s,n,m;
int vis[105][105][105];
struct node{
	int s,n,m;
	int step;
};
bool check(int x,int y,int z){
	return x == 0 && y == z || y == 0 && x == z || z == 0 && x == y;
}
int bfs(){
	if(s % 2) return 0;
	queue<node> q;
	node now,next;
	now.s = s,now.n = 0,now.m = 0,now.step = 0;
	q.push(now);
	vis[s][0][0] = 1;
	while(q.size()){
		now = q.front();
		q.pop();
		if(check(now.s,now.n,now.m)){
			return now.step;
		}
		// s-->n
		if(now.s && now.n < n){      // s不为空且n未满 
			if(now.s < n - now.n){  //s无法倒满n 
 				next.n = now.n + now.s;
				next.s = 0;
				next.m = now.m;
			}
			else{                    //s可以倒满 n 
				next.s = now.s - (n - now.n);
				next.n = n;
				next.m = now.m;
			}
			if(!vis[next.s][next.n][next.m]){
				next.step = now.step + 1;
				vis[next.s][next.n][next.m] = 1;
				q.push(next);
			}
		}
			// s-->m
		if(now.s && now.m < m){      // s不为空且m未满 
			if(now.s < m - now.m){  //s无法倒满m 
 				next.m = now.m + now.s;
				next.s = 0;
				next.n = now.n;
			}
			else{                    //s可以倒满 m 
				next.s = now.s - (m - now.m);
				next.m = m;
				next.n = now.n;
			}
			if(!vis[next.s][next.n][next.m]){
				next.step = now.step + 1;
				q.push(next);
				vis[next.s][next.n][next.m] = 1;
			}
		}
			// n-->s
		if(now.n && now.s < s){      // n不为空且s未满 
			if(now.n < s - now.s){  //n无法倒满s 
 				next.s = now.s + now.n;
				next.n = 0;
				next.m = now.m;
			}
			else{                    //n可以倒满 s 
				next.n = now.n - (s - now.s);
				next.s = s;
				next.m = now.m;
			}
			if(!vis[next.s][next.n][next.m]){
				next.step = now.step + 1;
				q.push(next);
				vis[next.s][next.n][next.m] = 1;
			}
		}
		// n-->m
		if(now.n && now.m < m){      // n不为空且m未满 
			if(now.n < m - now.m){  //n无法倒满m 
 				next.m = now.m + now.n;
				next.n = 0;
				next.s = now.s;
			}
			else{                    //n可以倒满 m 
				next.n = now.n - (m - now.m);
				next.m = m;
				next.s = now.s;
			}
			if(!vis[next.s][next.n][next.m]){
				next.step = now.step + 1;
				q.push(next);
				vis[next.s][next.n][next.m] = 1;
			}
		}
			// m-->s
		if(now.m && now.s < s){      // m不为空且s未满 
			if(now.m < s - now.s){  //m无法倒满s
 				next.s = now.s + now.m;
				next.m = 0;
				next.n = now.n;
			}
			else{                    //m可以倒满 s 
				next.m = now.m - (s - now.s);
				next.s = s;
				next.n = now.n;
			}
			if(!vis[next.s][next.n][next.m]){
				next.step = now.step + 1;
				q.push(next);
				vis[next.s][next.n][next.m] = 1;
			}
		}
		// m-->n
		if(now.m && now.n < n){      // m不为空且n未满 
			if(now.m < n - now.n){  //m无法倒满n 
 				next.n = now.n + now.m;
				next.m = 0;
				next.s = now.s;
			}
			else{                    //m可以倒满 n 
				next.m = now.m - (n - now.n);
				next.n = n;
				next.s = now.s;
			}
			if(!vis[next.s][next.n][next.m]){
				next.step = now.step + 1;
				q.push(next);
				vis[next.s][next.n][next.m] = 1;
			}
		}
	}
	return 0;
}
int main()
{
	while(cin>>s>>n>>m&&s&&n&&m){
		memset(vis,0,sizeof(vis));
		int ans = bfs();
		if(ans == 0) cout<<"NO"<<endl;
		else cout<<ans<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值