题目描述
最新的火星探测机器人curiosity被困在了一个二维迷宫里,迷宫由一个个方格组成。
共有四种方格:
‘.’ 代表空地,curiosity可以穿过它
‘#’ 代表障碍物,不可穿越,不可停留
‘S’ 代表curiosity的起始位置
‘T’ 代表curiosity的目的地
NASA将会发送一系列的命令给curiosity,格式如下:“LRUD”分别代表向左,向右,向上,向下走一步。由于地球和火星之间最近时也有55000000km!所以我们必须提前判断这一系列的指令会让curiosity最终处在什么样的状态,请编程完成它。
输入
第一行是一个整数T,代表有几个测试样例
每个测试样例第一行是一个整数N(1< =N< =50))代表迷宫的大小(N*N)。随后的N行每行由N个字符串组成,代表迷宫。接下来的 一行是一个整数Q,代表有多少次询问,接下来的Q行每行是一个仅由“LRUD”四个字母的组成的字符串,字符转长度小于1000.
输出
对于每个询问输出单独的一行:
“I get there!”:执行给出的命令后curiosity最终到达了终点。
“I have no idea!”:执行给出的命令后curiosity未能到达终点。
“I am dizzy!”:curiosity在执行命令的过程中撞到了障碍物。
“I am out!”:代表curiosity在执行命令的过程中走出了迷宫的边界。
样例输入
2
2
S.
#T
2
RD
DR
3
S.#
.#.
.T#
3
RL
DDD
DDRR
样例输出
I get there!
I am dizzy!
I have no idea!
I am out!
I get there!
import java.util.*;
public class Main {
static String[] maze = new String[55];
static Map<Character,Integer> map = new HashMap<Character, Integer>();
static int []dx = {-1,0,1,0};
static int []dy = {0,1,0,-1};
static int m;
public static void main(String[] args) {
map.put('U', 0);
map.put('R', 1);
map.put('D', 2);
map.put('L', 3);
Scanner sc = new Scanner(System.in);
int t = sc.nextInt();
while(t != 0) {
t --;
int x = 0;
int y = 0;
m = sc.nextInt();
for(int i = 0;i < m;i ++) {
maze[i] = sc.next();
for(int j = 0;j < m;j ++) {
if(maze[i].charAt(j) == 'S') {
x = i;
y = j;
}
}
}
int k = sc.nextInt();
for(int i = 0;i < k;i ++) {
String cmd = sc.next();
int ans = walk(cmd,x,y);
if(ans == 1) {
System.out.println("I get there!");
}
else if(ans == 2) {
System.out.println("I have no idea!");
}
else if(ans ==3) {
System.out.println("I am dizzy!");
}
else {
System.out.println("I am out!");
}
}
}
}
public static int walk(String cmd,int x,int y) {
for(int i = 0;i < cmd.length();i ++) {
int loc = map.get(cmd.charAt(i));
x += dx[loc];
y += dy[loc];
if(x < 0 || x >= m || y < 0 || y >= m) return 4;
else if(maze[x].charAt(y)== '#') return 3;
else if (maze[x].charAt(y)== 'T') return 1;
}
return 2;
}
}