Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).
To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.
Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).
FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.
Input
Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.
Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
Sample Input
25 5 2 2 14 11 21 17
Sample Output
4
Hint
Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
题意
有个地方每年都会举办一个跳跳游戏,在一条长为l的河上放了n块石头,然后让牛从这几块石头跳到终点,强子家的牛每年都拿冠军,所以他就膨胀了,他想给比赛加点难度,因此他打算挖掉m块石头,让石头间的最小距离变大,问你最大的最小距离是多少?
分析
1.首先肯定是用二分,最小值取零,最大值取河道的长度。
2.判定条件:两块相邻石头距离如果超过mid,就判断下两个。如果小于,前面的不动,找到最近的相距超过mid的石块,累加中间跳过的石块数一,旦累加的石块数超过了m就说明mid的值太大了。而如果累加完毕未超过m,则表示可行,但不一定是最优。
AC代码
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<sstream>
using namespace std;
int n,m;
int l,a[50005];
bool test (int mid)
{
int last=0,num=0,i=0;
while(i<=n)
{
if(a[i]-last<mid)
{
int cur=i+1;
while(cur<=n&&a[cur]-last<mid)
cur++;如果石块之间的距离小于mid,则跳过这个石块
num+=cur-i;
累加跳过的石块
if(num>m)
return false;
i=cur;
}
last=a[i];
i++;
}
return true;
}
int main()
{
while(cin>>l>>n>>m)
{
int left=0,right=l,mid,ans;
for(int i=0;i<n;i++)
cin>>a[i];
a[n]=l;
sort(a,a+n);
while(right>=left)
{
mid=(right+left)/2;
if(test(mid))
{
ans=mid;
left=mid+1;
}
else
right=mid-1;
}
cout<<ans<<endl;
}
return 0;
}