C - Domination UVALive - 6972

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What’s more, he bought a large decorative chessboard with N rows and M columns.

 

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

 

“That’s interesting!” Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 ≤ N, M ≤ 50).

 

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10−8 will be accepted.

 

Sample Input

2

1 3

2 2

 

SampleOutput

 

3.000000000000

 

2.666666666667

题意

这道题是让我们求期望,

在一个n行m列的棋盘上,随机放置棋子,

需要多少棋子能够保证每一行,每一列都有一个棋子,

我们需要求的就是棋子的期望

分析

要实现题目的要求

首先我们要求用n颗棋子恰占满每一行每一列的概率

然后将n乘上他的概率

最后将他们都加起来

得到他的期望

AC代码

#include<bits/stdc++.h>
using namespace std;
double dp[2505][51][51];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int N,M;
		cin>>N>>M; 
		memset(dp,0,sizeof(dp));
		dp[0][0][0]=1;
		//---------------------------------
		 for(int k = 0; k <= N*M; k++)//求概率
        {
            for(int i = 0; i <= N; i++)
            {
                for(int j = 0; j <= M; j++)
                {
                    if(i == N && j == M || dp[k][i][j] == 0)
						continue;
                    if(i * j >= k)
                        dp[k+1][i][j] += dp[k][i][j] * (i * j - k) / (N * M - k);
                    if(i < N)
                        dp[k+1][i+1][j] += dp[k][i][j] * (N - i) * j / (N * M - k);
                    if(j < M)
                        dp[k+1][i][j+1] += dp[k][i][j] * (M - j) * i / (N * M - k);
                    if(i < N && j < M)
                        dp[k+1][i+1][j+1] += dp[k][i][j] * (N - i) * (M - j) / (N * M - k);
                }
            }
        }
		//---------------------------------
		double ans = 0;
        for(int i = 0; i <= N*M; i++)//求期望
            ans += i * dp[i][N][M];
        printf("%.12lf\n", ans);
	}
	
  	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值