程序设计与算法(二)第八周测验 2:A Knight's Journey

2:A Knight's Journey

总时间限制: 

1000ms

 

内存限制: 

65536kB

描述

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

输入

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

输出

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

样例输入

3
1 1
2 3
4 3

样例输出

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include <stdio.h>
#include <string.h>
//#define mem(a,b) memset(a,b,sizeof(a)) 
const int maxn=30;
int vis[maxn][maxn];//判断是否遍历过该节点 
int n,m,flag;//flag为判断骑士能否走完地图 
int go[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//按字典顺序的走法,为什么这是字典顺序,因为列从左到右是字典顺序 
struct Node{
	int x;
	int y;
}a[maxn];//存储每一步的坐标 

void DFS(int x,int y,int step){
	int i;
	a[step].x=x;//把当前路径放入结构体数组中 
	a[step].y=y;//同上 
	if(step==n*m){//如果步数已经等于方块数了 
		for(i=1;i<=step;i++){//则输出每一步的坐标 
			printf("%c%d",a[i].y-1+'A',a[i].x);
		}
		printf("\n");
		flag=1;//表示可以走完 
	}
	
	if(flag){
		return ;
	}
	
	for(i=0;i<8;i++){//有8种走法 
		int xx=x+go[i][0];
		int yy=y+go[i][1];
		if(xx>0&&xx<=n&&yy>0&&yy<=m&&vis[xx][yy]==0){//判断是否越界和是否遍历过 
			vis[xx][yy]=1;
			DFS(xx,yy,step+1);
			vis[xx][yy]=0;//走到头,不能继续了,就回最初结点,走另一种情况 
		}
	}
}

int main()
{
	int i,j;
	int t,cnt=1;
	scanf("%d",&t);
	while(t--){
		//mem(vis,0);
		memset(vis,0,sizeof(vis));//初始化vis 
		flag=0;//初始化为0 
		scanf("%d %d",&n,&m);
		printf("Scenario #%d:\n",cnt++);
		vis[1][1]=1;//把第一个标记出来,然后从第一个开始 
		DFS(1,1,1);
		if(flag==0){
			printf("impossible\n");
		}
		printf("\n");
	}
	return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值