acm2031java_杭电ACM2031java做法

进制转换

Problem Description

输入一个十进制数N,将它转换成R进制数输出。

Input

输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。

Output

为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。

Sample Input

7 2

23 12

-4 3

Sample Output

111

1B

-11

import java.io.BufferedInputStream;

import java.util.Scanner;

public class P2031 {

static void f(int n, int r) {

if(n != 0) {

f(n / r, r);

System.out.print((char)(n % r > 9 ? n%r-10 + 'A' : n%r + '0') );

}

}

/**

* TODO

* @return_type void

* @param args

*/

public static void main(String[] args) {

// TODO Auto-generated method stub

Scanner s = new Scanner(new BufferedInputStream(System.in));

int n, r;

while(s.hasNext()) {

n = s.nextInt();

r = s.nextInt();

if(n > 0) {

f(n, r);

System.out.println();

}

else if(n == 0)

System.out.println('0');

else {

System.out.print('-');

f(-n, r);

System.out.println();

}

}

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值