题目
总时间限制: 1000ms 内存限制: 65536kB
描述
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
输入
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
输出
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
样例输入
6 9
…#.
…#
…
…
…
…
…
#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.
…
11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
样例输出
45
59
6
13
思路
DFS
CODE
#include<iostream>
using namespace std;
const int MAX = 30;
char map[MAX][MAX];
bool visit[MAX][MAX];
int w, h;
int sum;
int dx[4] = { 0,0,1,-1 };
int dy[4] = { -1,1,0,0 };
void dfs(int x, int y)
{
if (x < 0 || x >= h || y < 0 || y >= w)
return;
if (map[x][y] == '#')return;
if (visit[x][y])return;
sum++;
visit[x][y] = true;
for (int i = 0; i < 4; i++)
{
dfs(x + dx[i], y + dy[i]);
}
}
int main()
{
int i, j;
int stax, stay;
while (cin >> w >> h)
{
if (w == 0 && h == 0)
{
break;
}
for (i = 0; i < h; i++)
{
for (j = 0; j < w; j++)
{
visit[i][j] = false;
cin >> map[i][j];
if (map[i][j] == '@')
{
stax = i;
stay = j;
}
}
}
sum = 0;
dfs(stax, stay);
cout << sum << endl;
}
system("pause");
return 0;
}