hdu1042 java_HDU-1042 高精 java

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 41798    Accepted Submission(s): 11627

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1

2

3

Sample Output

1

2

6

用java写高精度比较靠谱。

[java]

package lixiangmao;

import java.math.BigInteger;

import java.util.Scanner;

public class HDU1042{

public static void main(String[] argc)

{

Scanner cin = new Scanner(System.in);

BigInteger a,n,i;

while(true)

{

a = cin.nextBigInteger();

n = BigInteger.ONE;

for(i=BigInteger.ONE; i.compareTo(a) <= 0; i = i.add(BigInteger.ONE))

n = n.multiply(i);

System.out.println(n);

}

}

}

package lixiangmao;

import java.math.BigInteger;

import java.util.Scanner;

public class HDU1042{

public static void main(String[] argc)

{

Scanner cin = new Scanner(System.in);

BigInteger a,n,i;

while(true)

{

a = cin.nextBigInteger();

n = BigInteger.ONE;

for(i=BigInteger.ONE; i.compareTo(a) <= 0; i = i.add(BigInteger.ONE))

n = n.multiply(i);

System.out.println(n);

}

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值