priority_queue:优先队列

#include<queue>

模板声明带3个参数:priority_queue<Type, Container, Functional>,其中Type 为数据类型,Container为保存数据的容器,Functional 为元素比较方式。

Container必须是用数组实现的容器,比如vector,qeque等等,但不能用 list。STL里面默认用的是vector。

比较方式默认用operator<,所以如果把后面2个参数缺省的话,优先队列就是降序,队头元素最大。
第三个参数是一个比较类,less 表示数字大的优先级高,而 greater 表示数字小的优先级高。

尽管队列和优先队列都是在queue里的,但是队列的队首是front来获得,而优先队列的队首是top来获得

HDU 4006 The kth great number
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.
Output
The output consists of one integer representing the largest number of islands that all lie on one line.
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3
Hint
Xiao Ming won’t ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

#include <iostream>
#include <cstdio>
#include <cstring> 
#include <string>
#include <map> 
#include <set>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;

int main()
{
	int n, k, t;
	char s[5];
	while (scanf("%d%d", &n, &k)!=EOF){
		priority_queue<int, vector<int>, greater<int> > q;
		for (int i=1; i<=n; i++){
			scanf("%s", s);
			if (s[0]=='I'){
				scanf("%d", &t);
				q.push(t);
				if (q.size()>k)	q.pop();
			}else
				printf("%d\n", q.top());
		}
	}
	return 0;
}

HDU 3785 寻找大富翁
浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.
Input
输入包含多组测试用例.
每个用例首先包含2个整数n(0<n<=100000)和m(0<m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值.
n和m同时为0时表示输入结束.
Output
请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.
Sample Input
3 1
2 5 -1
5 3
1 2 3 4 5
0 0
Sample Output
5
5 4 3

#include <iostream>
#include <cstdio>
#include <cstring> 
#include <string>
#include <map> 
#include <set>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;

int main()
{
	int n, m, t;
	while (scanf("%d%d", &n, &m)!=EOF){
		if (n==0 && m==0)	break;
		priority_queue<int, vector<int>, less<int> > q;
		for (int i=1; i<=n; i++){
			scanf("%d", &t);
			q.push(t);
		}
		if (q.size()>m){
			printf("%d", q.top());
			q.pop();
			for (int i=2; i<=m; i++){
				printf(" %d", q.top());
				q.pop();
			}
		}else{
			printf("%d", q.top());
			while (!q.empty()){
				printf(" %d", q.top());
			}
		}
		printf("\n");
	}
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

H4ppyD0g

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值