HDU 1018 Big Number(斯特林公式)

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
2
10
20
Sample Output
7
19

斯特林公式:用于求n阶乘的近似值
在这里插入图片描述
两边同时取对数:lnN!=NlnN-N+0.5ln(2N*pi)
要想求有多少位,将他换成以10为底,求出数向下取整再加1.
利用换底公式得 lnN!/ln10=log10N!

#include <iostream>
#include <cstdio>
#include <cmath>
#define PI acos(-1.0)
using namespace std;

int solve(int n)
{
	return (int)((n*log(n)-n+(log(2*PI*n))/2)/log(10))+1;
}
int main()
{
	int t, n;
	scanf("%d", &t);
	while (t--){
		scanf("%d", &n);
		printf("%d\n", solve(n));
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

H4ppyD0g

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值