求字符串最长交集

描述

设有集合A和集合B,求A∩B的最长子集。

输入

A:asdfghjkla

B:wesdfghjeteya

A:I likeyou!

B:Realy,but I like your hat.It’s cool!

输出

sdfghj

I like you

输入样例 1

Hi,those are yours.

Un,no,those arn’t mine.

输出样例 1

,those ar

方法同找最长子串

#include<stdio.h>
#include<string.h>

int main(){
	char s1[100],s2[100];
	gets(s1);
	scanf("\n");
	gets(s2);
	int i,j,k;
	int max = 0;
	int start = 0;
	int len;
	for(i=0;i<strlen(s1);i++){
		for(j=0;j<strlen(s2);j++){
			len =  0;
			if(s1[i]==s2[j]){
				int a,b;
				for(a=i,b=j;a<strlen(s1)&&b<strlen(s2);a++,b++){
					if(s1[a]==s2[b]){
						len++;
					}else{
						break;
					}
				}
			}
			if(len>max){
				max = len;
				start = i;
			}
		}
	}
	for(k=start;k<start+max;k++){
		printf("%c",s1[k]);
	} 
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值