03-树2 List Leaves (25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
4 1 5

解题思路:
1.树的表示方法
2.树的读入
3.叶结点的判断

#include<iostream>
#include<queue>
#define MAXSIZE 10
#define Null -1
using namespace std;
struct Tree
{
	int OderNum;
	int Left;
	int Right;
};

Tree T1[MAXSIZE];
int ReadInput(Tree T[]);
int* SelectLeave(int R, Tree T[]);
int main()
{
	int R1,i=0;
	int* Lea;
	R1 = ReadInput(T1);
	Lea = SelectLeave(R1, T1);
	while (Lea[i] != Null)
	{
		if(i==0) cout << Lea[i];
		else cout << " " << Lea[i];
		i++;
	}
	system("pause");
}
int ReadInput(Tree T[])
{
	char left, right;
	int N, i = 0;
	int check[MAXSIZE];
	cin >> N;
	if (N == 0) return Null;
	for (i = 0; i < 10; i++) check[i] = 0;
	for (i = 0; i < N; i++)
	{
		cin >> left >> right;
		T[i].OderNum = i;
		if (left == '-')  T[i].Left = Null;
		else
		{
			T[i].Left = left - '0';
			check[T[i].Left] = 1;
		}
		if (right == '-') T[i].Right = Null;
		else
		{
			T[i].Right = right - '0';
			check[T[i].Right] = 1;
		}
	}
	for (i = 0; i < N; i++)
	{
		if (check[i] != 1) break;
	}
	return i;
}

int* SelectLeave(int R,Tree T[])
{
	static int Leave[MAXSIZE];
	queue<int> M;
	int head, k=0;
	for (int i = 0; i < MAXSIZE; i++) Leave[i] = Null;
	M.push(R);
	while (!M.empty())
	{
		head = M.front();
		M.pop();
		if (T[head].Left == Null&&T[head].Right == Null) Leave[k++] = head;
		if(T[head].Left != Null) M.push(T[head].Left);
		if (T[head].Right != Null)M.push(T[head].Right);
	}
	return Leave;
}

问题汇总:函数如果返回的是函数内部声明的数组名的话,得到的返回值只是数组的第一个元素即是数组下标为0的元素值。而其他元素都是不确定的随机的值,这是因为函数调用结束后,会将函数使用过的内存释放,这样的话除了数组第一个元素的值以外的值都会被释放。如果要返回整个是数组,需要将数组声明为全局变量即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值