02-线性结构4 Pop Sequence

02-线性结构4 Pop Sequence

来自:PTA_数据结构_Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:
YES
NO
NO
YES
NO

程序代码:

#include <stdio.h>
#include <stdlib.h>

typedef int ElementType;
typedef struct SNode *Stack;
struct SNode {
    ElementType *Data;
    int Top;
};

void makeEmpty(Stack stack)
{
    stack->Top = -1;
}

int isEmpty(Stack stack)
{
    return stack->Top == -1 ? 1 : 0;
}

void push(Stack stack, ElementType data, int M)
{
    if (stack->Top == M - 1)
        return;
    else
        stack->Data[++(stack->Top)] = data;
}

ElementType pop(Stack stack)
{
    if (stack->Top == -1)
        return NULL;
    else
        return stack->Data[(stack->Top)--];
}

ElementType getTopElem(Stack stack)
{
    if (stack->Top == -1)
        return NULL;
    return stack->Data[stack->Top];
}

int check(int *seq, int N, Stack stack, int M)
{
    int i, flag;
    ElementType push_item;
    makeEmpty(stack);
    push_item = 1;
    flag = 1;
    /*根据栈的后进先出的规律:进栈的时候按照1,2...N的顺序,
    然后根据所给序列,检验出栈的逻辑是否可行。
    很绕,多想一想*/
    for (i = 0; i < N; ++i) {   
        while (getTopElem(stack) != seq[i] && push_item <= N) {
            push(stack, push_item++, M);
        }
        if (getTopElem(stack) == seq[i]) {
            pop(stack);
        } else {
            flag = 0;
            break;
        }
    }

    return flag;
}

int main()
{
    int M, N, K, *seq, ans, i, j;
    Stack stack;
    stack = (Stack)malloc(sizeof(struct SNode));
    scanf("%d %d %d", &M, &N, &K);
    stack->Data = (ElementType *)malloc(M * sizeof(ElementType));
    seq = (int *)malloc(N * sizeof(int));
    for (i = 0; i < K; ++i) {
        for (j = 0; j < N; ++j)
            scanf("%d", &seq[j]);
        ans = check(seq, N, stack, M);
        if (ans)
            printf("YES\n");
        else
            printf("NO\n");
    }

    free(stack->Data);
    free(stack);
    free(seq);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值