PAT甲级刷题记录——1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

思路

这题我用静态二叉树的方法来写哈(楼主比较菜),这里受到了题目【1064 Complete Binary Search Tree (30分)】的启发:用中序序列来建立一棵BST。

因为题目已经给出了所有结点的父亲孩子关系(每行给出第i个结点的左右孩子,比如第一行是结点0的左孩子1,右孩子6),所以这和完全二叉树那道题类似(完全二叉树其实也是规定好了父子关系:结点x的左孩子是2x,右孩子是2x+1),建立出来的BST一定也是唯一的(本题就相当于是给出一些像图1一样的空格,然后往里面填数字,填出来的数字正好要满足BST的性质)。

接下来的做法就很简单了,和CBT那题完全一样:①把所给的序列按从小到大的顺序排序,于是得到中序序列;②进行中序遍历,每次访问根结点的时候按序列从头到尾填数;③以上两步做完之后已经得到满足题目要求的BST了,再用BFS进行层序遍历就行了。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 110;
int Data[maxn] = {0};
struct node{
    int data;
    int lchild;
    int rchild;
}Node[maxn];
int Index = 0;
void inorder(int root){
    if(root==-1) return;
    inorder(Node[root].lchild);
    Node[root].data = Data[Index++];
    inorder(Node[root].rchild);
}
void levelorder(int root, int &cnt){
    queue<int> q;
    q.push(root);
    while(!q.empty()){
        int top = q.front();
        q.pop();
        if(cnt==0){
            printf("%d", Node[top].data);
            cnt++;
        }
        else{
            printf(" %d", Node[top].data);
            cnt++;
        }
        if(Node[top].lchild!=-1) q.push(Node[top].lchild);
        if(Node[top].rchild!=-1) q.push(Node[top].rchild);
    }
}
int main(){
    int N;
    scanf("%d", &N);
    for(int i=0;i<N;i++){
        scanf("%d%d", &Node[i].lchild, &Node[i].rchild);
    }
    for(int i=0;i<N;i++){
        scanf("%d", &Data[i]);
    }
    sort(Data, Data+N);
    inorder(0);
    int cnt = 0;
    levelorder(0, cnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值