PAT甲级刷题记录——1093 Count PAT's (25分)

The string APPAPTcontains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

思路

这题借鉴了柳神的思路哈,大体的想法就是对每一个A,只要找到左边P的个数和右边T的个数,然后两者相乘,就是当前这个A能形成的PAT的数量,但是呢,这么直观地做又有个麻烦,如果字符串很长呢,如果A的数量恰好又很多呢?那岂不是在一个for循环寻找A的过程中,还要再两个for循环寻找左边的P和右边的T,这样的话估计肯定就超时了(时间限制只有150ms)。

因此,我们可以先遍历一遍字符串,找到T的所有个数,然后再遍历一遍字符串,此时,每遇到一个P,就cntP++,每遇到一个A,执行一次cntP*cntT的操作,每遇到一个T,就cntT–(说明当前T在取下个A的时候不能用了,因为T在A的前面),最后把结果取模就行啦~为了防止溢出,我用long long来存了计算出来的结果。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
    string tmp;
    cin>>tmp;
    int cntT = 0, cntP = 0;
    long long result = 0;
    for(int i=0;i<tmp.length();i++){
        if(tmp[i]=='T') cntT++;
    }
    for(int i=0;i<tmp.length();i++){
        if(tmp[i]=='P') cntP++;
        if(tmp[i]=='A'){
            result += cntP*cntT;
        }
        if(tmp[i]=='T') cntT--;
    }
    cout<<result%1000000007;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值