PAT甲级刷题记录——1028 List Sorting (25分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​ ) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

思路

这题很简单哈,题目大意就是给出N个人的信息,然后再给定一个C,根据C=1、2、3分别对应三种情况进行排序~

唯一要注意的一个点就是【If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order】,即:同名或者同成绩的话(第一标尺),ID要按升序排列(第二标尺)。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<vector>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
struct student{
    string id, name;
    int grade;
};
vector<student> List;
bool cmp1(student a, student b){
    return a.id<b.id;
}
bool cmp2(student a, student b){
    if(a.name!=b.name) return a.name<b.name;
    else return a.id<b.id;
}
bool cmp3(student a, student b){
    if(a.grade!=b.grade) return a.grade<b.grade;
    else return a.id<b.id;
}
int main()
{
    int N, C;
    cin>>N>>C;
    for(int i=0;i<N;i++){
        string tmpid, tmpname;
        int tmpgrade;
        student tmp;
        cin>>tmpid>>tmpname>>tmpgrade;
        tmp.id = tmpid;
        tmp.name = tmpname;
        tmp.grade = tmpgrade;
        List.push_back(tmp);
    }
    if(C==1) sort(List.begin(), List.end(), cmp1);
    else if(C==2) sort(List.begin(), List.end(), cmp2);
    else sort(List.begin(), List.end(), cmp3);
    for(int i=0;i<List.size();i++){
        cout<<List[i].id<<" "<<List[i].name<<" "<<List[i].grade<<'\n';
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值