PAT甲级1004 Counting Leaves (30分)|C++实现

一、题目描述

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

​​Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

二、解题思路

这道题主要考察了树的层序遍历,很容易理解的是,树的层序遍历是可以利用队列这个数据结构来完成的,所以我们会用到STL的queue。有一个需要注意的点,就是M=0的时候,没有非叶节点,也就是说整个树中只有叶子节点,那么显然,这个树就仅有一个节点,也只有1层,输出1即可。每个节点我们用一个结构体Node来表示,Node包含节点的层数,以及它的孩子的编号,层数我们可以用一个整型变量表示,它的孩子可以用vector存储。将树构建好后,构建计算每层叶子节点数的数组countL[],下标则对应层数,对树进行层序遍历,看孩子数是否为0,若孩子数为0,则对应的层的叶子节点数就加1。最后遍历countL数组,输出即可。

三、AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 110;
int countL[maxn] = {0};
struct Node
{
  int level;
  vector<int> children;
}node[maxn];
int main()
{
  int N, M, K, tmp1, tmp2, maxlevel = 0;
  scanf("%d%d", &N, &M);
  if(M==0)	//特判
  {
    printf("1");
    return 0;
  }
  node[1].level = 1;
  for(int i=1; i<=M; i++)
  {
    scanf("%d%d", &tmp1, &K);
    for(int j=0; j<K; j++)
    {
      scanf("%d", &tmp2);
      node[tmp1].children.push_back(tmp2);
    }
  }
  for(int i=1; i<=N; i++) //遍历所有节点
  {
    for(int j=0; j<node[i].children.size(); j++)
    {
      node[node[i].children[j]].level = node[i].level+1;
      if(maxlevel < node[node[i].children[j]].level)	maxlevel = node[node[i].children[j]].level;
    }
  }
  queue<Node> q;
  q.push(node[1]);
  while(!q.empty())
  {
    Node temp = q.front();
    if(temp.children.size()==0)	//孩子数为0,则为叶子节点
    	countL[temp.level]++;
    q.pop();
    for(int i=0; i<temp.children.size(); i++)
      q.push(node[temp.children[i]]);
  }
  for(int i=1; i<=maxlevel; i++)
  {
    if(i==1)	printf("%d", countL[i]);
    else	printf(" %d", countL[i]);
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值