PAT甲级1007 Maximum Subsequence Sum (25分)|C++实现

一、题目描述

Given a sequence of K integers { N 1 , . . . , N k N_1, ... , N_k N1,...,Nk}. A continuous subsequence is defined to be { N i , N i + 1 , . . . , N j N_{i}, N_{i+1}, ... , N_j Ni,Ni+1,...,Nj} where 1 ≤ i ≤ j ≤ K 1\leq i \leq j \leq K 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2}, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K ( ≤ 10000 ) K(\leq10000) K(10000). The second line contains K K K numbers, separated by a space.

​​Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

二、解题思路

这道题还是比较难想的,如果直接用遍历的方法,会导致有测试点超时。所以我们这里可以采用动态规划的解法。建立一个数组store[],store[i]则表示第i+1个元素(因为数组下标从0开始)。用tmp来表示以当前这个数结尾的最大子列和,如果这个tmp小于0,那么显然,以下一个数结尾的最大子列和一定就是它本身,比如{ -11, 10, -21, -4},-11是以第一个数为结尾的最大子列和,小于0,那么以10结尾的最大子列和就是10本身。然后用一个变量sum记录最大子列和,此外,我们还要记录标号,用l和r记录左边和右边那个数的下标。最后加一个关于sum<0的特判即可。

三、AC代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn = 10001;
int store[maxn];
int main()
{
    int K, tmp = 0, sum = -1, l, r, tmpidx = 1;
    scanf("%d", &K);
    l = 1;
    r = K;
    for(int i=1; i<=K; i++)
    {
        scanf("%d", &store[i]);
        tmp += store[i];
        if(tmp< 0)
        {
            tmp = 0;
            tmpidx = i + 1;
        }
        else if(tmp > sum)
        {
            sum = tmp;
            l = tmpidx;
            r = i;
        }
    }
    if(sum < 0)	sum = 0;
    printf("%d %d %d", sum, store[l], store[r]);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值