PAT甲级1058 A+B in Hogwarts (20分)|C++实现

一、题目描述

原题链接
在这里插入图片描述

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

​​Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

二、解题思路

简单的一道加法模拟题。对于Knut,我们直接将两者相加然后对29取模即可,如果两者相加大于29,我们还要把carry变量变为1。其余位数同理。

三、AC代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int G[2], S[2], K[2];
void Add()
{
    int g, s, k;
    int carry = 0;
    k = (K[0]+K[1])%29;
    if(K[0] + K[1] >= 29)   carry = 1;
    s = (carry + S[0] + S[1])%17;
    carry = carry + S[0] + S[1] >= 17 ? 1 : 0;
    g = carry + G[0] + G[1];
    printf("%d.%d.%d", g, s, k);
    return;
}
int main()
{
    scanf("%d.%d.%d", &G[0], &S[0], &K[0]);
    scanf("%d.%d.%d", &G[1], &S[1], &K[1]);
    Add();
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值