PAT甲级1139 First Contact (30分)|C++实现

一、题目描述

原题链接
Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

​​Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

二、解题思路

这道题目不太难,但是有点复杂,用了很多层的循环遍历,因为题目的数据量不大,所以并没有超时,但是代码写的还是比较难看的。开一个数组标志每个人的性别,用邻接表存放每个人的朋友,之后进行层层遍历即可。详情见代码注释。

三、AC代码

#include<iostream>
#include<cstdio>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct Edge
{
    int a, b;
};
bool cmp(Edge e1, Edge e2)
{return e1.a == e2.a ? (e1.b < e2.b) : (e1.a < e2.a);}
vector<Edge> ans;
vector<int> Adj[10000];
bool boy[10000] = {0};
int main()
{
    int N, M, K;
    string a, b;
    int aint, bint;
    scanf("%d%d", &N, &M);
    for(int i=0; i<M; i++)
    {
        cin >> a >> b;
        aint = abs(stoi(a));
        bint = abs(stoi(b));
        if(a[0] == '-')    boy[aint] = -1;
        if(b[0] == '-')    boy[bint] = -1;
        Adj[aint].push_back(bint);
        Adj[bint].push_back(aint);
    }
    scanf("%d", &K);
    for(int i=0; i<K; i++)
    {
        cin >> a >> b;
        aint = abs(stoi(a));
        bint = abs(stoi(b));
        ans.clear();
        for(int j=0; j<Adj[aint].size(); j++)
        {
            if(boy[Adj[aint][j]] == boy[aint] && Adj[aint][j] != bint)  //a b不直接认识,遍历a的朋友
            {
                for(int k=0; k<Adj[Adj[aint][j]].size(); k++)   //遍历这个朋友的所有朋友
                {
                    if(boy[Adj[Adj[aint][j]][k]] == boy[bint])  //找到和b性别相同的
                    {
                        for(int l=0; l<Adj[bint].size(); l++)   //遍历b的朋友,锁定同一个人
                        {
                            if(Adj[bint][l] == Adj[Adj[aint][j]][k] && Adj[Adj[aint][j]][k] != aint) //第二个条件测试点4
                            {
                                Edge tmp;
                                tmp.a = Adj[aint][j];
                                tmp.b = Adj[bint][l];
                                ans.push_back(tmp);
                            }
                        }
                    }
                }
            }
        }
        int sze = ans.size();
        printf("%d\n", sze);
        sort(ans.begin(), ans.end(), cmp);
        for(int i=0; i<sze; i++)
        {
            printf("%04d %04d\n", ans[i].a, ans[i].b);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值