【Codeforces】1217B - Zmei Gorynich

Problem Description:

You are fighting with Zmei Gorynich — a ferocious monster from Slavic myths, a huge dragon-like reptile with multiple heads!

 

Initially Zmei Gorynich has xx heads. You can deal nn types of blows. If you deal a blow of the ii-th type, you decrease the number of Gorynich's heads by min(di,curX)min(di,curX), there curXcurX is the current number of heads. But if after this blow Zmei Gorynich has at least one head, he grows hihi new heads. If curX=0curX=0 then Gorynich is defeated.

You can deal each blow any number of times, in any order.

For example, if curX=10, d=7, h=10 then the number of heads changes to 13 (you cut 7 heads off, but then Zmei grows 10 new ones), but if curX=10, d=11, h=100 then number of heads changes to 0 and Zmei Gorynich is considered defeated.

Calculate the minimum number of blows to defeat Zmei Gorynich!

You have to answer t independent queries.

Input Specification:

The first line contains one integer t (1 ≤ t ≤ 100) – the number of queries.

The first line of each query contains two integers n and x (1 ≤ n ≤ 100, 1 ≤ x ≤ 109) — the number of possible types of blows and the number of heads Zmei initially has, respectively.

The following n lines of each query contain the descriptions of types of blows you can deal. The ii-th line contains two integers di and hi (1 ≤ di,hi ≤ 109) — the description of the i-th blow.

Output Specification:

For each query print the minimum number of blows you have to deal to defeat Zmei Gorynich.

If Zmei Gorynuch cannot be defeated print −1.

Sample Input:

3
3 10
6 3
8 2
1 4
4 10
4 1
3 2
2 6
1 100
2 15
10 11
14 100

Sample Output:

2
3
-1

解题思路:

题目大意是用n种攻击类型去杀一个有x个头的怪物,它没有脑袋了就会死掉,你攻击能伤害它d个头,只要它还活着就能长出h个头,请选择有效的攻击类型来用最少的攻击次数击败它。贪心算法,ans是最大有效伤害,maxd是斩杀线也是最大攻击伤害,需要注意最大有效伤害不一定是最大攻击伤害。若有效伤害不为正 说明伤害太低,无法击杀怪物。若怪物的脑袋数低于斩杀线,则能一次击杀怪物。若一次不能斩杀,剩下的脑袋就用有效伤害来计算,-1是因为当括号内的值恰好等于有效伤害ans时可以完成击杀,最后的+1是因为斩杀线maxd的那次攻击没有计算在内。

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define Up(i,a,b) for(int i = a; i <= b; i++)

int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin >> t;
    while(t--)
    {
        int n,x;
        cin >> n >> x;
        int d[n+1],h[n+1];
        int ans = -1,maxd = -1;   //ans最大有效伤害,maxd最大攻击伤害即斩杀线
        Up(i,1,n)
        {
            cin >> d[i] >> h[i];
            ans = max(ans,d[i]-h[i]);
            maxd = max(maxd,d[i]);
        }
        if(maxd >= x)   //低于斩杀线,可以一次击杀
        {
            cout << 1 << endl;
        }
        else if(ans <= 0)   //伤害太低,无法击杀
        {
            cout << -1 << endl;
        }
        else
        {    //x减去斩杀线maxd后,剩下的脑袋用最大有效伤害值来计算,-1是括号内的值刚好等于ans时可以击杀掉
            cout << (x-maxd+ans-1)/ans+1 << endl;   //+1是斩杀线那一刀
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

喜欢ctrl的cxk

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值