1085 Perfect Sequence (25 分)

1085 A Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5
​​ ) is the number of integers in the sequence, and p (≤105
​​ )
is the parameter. In the second line there are N positive integers, each is no greater than 10
​9

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
​​ .

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

思考和思路

  1. .排序,从小到大
  2. 从第0个元素开始,逐个向后找,寻找第一个大于value*arr[i]的数组元素。这里我们使用upper_bound, 得到第一个相关元素的地址,然后得到下标i,i- 1完美数组片段最后一个元素的位置。

答案1(通过,二分法)

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int arr[maxn];
int main()
{
	int N;
	int value;
	scanf("%d %d",&N,&value);
	for(int i = 0; i < N; i++) {
		scanf("%d",&arr[i]);
	}
	sort(arr ,arr + N);
	
//	//test 输出排序后的元素 
//	for(int i = 0; i< N; i ++) {
//		printf("%d ",arr[i]);
//	} 
//	
	//开始求最长数组片段长度 
	int maxlen = -1;
	for(int i = 0; i < N; i ++) {
		int len = upper_bound(arr + i + 1,arr + N,(long long )(arr[i] * value)) - arr; //用long long 是因为两个值的乘积可能大于long的最大范围 
		//upper_bound 二分查找函数,只能在增序中查找。
		//三个参数分别是,首地址,终地址,num。 
		// 返回第一个大于num的数组元素的 地址end。 
			//end - 数组首地址 = 下标 
		maxlen = max(len - i,maxlen);
	} 
	
	printf("%d",maxlen);
}

答案2(使用two pointer,有一个错误)

错误是因为我的这种方法做不到最优解。pointer的移动有概率因素在里面。
这里写的two pointer分别在数组的头和尾。
最优的是 两个pointer都在头部。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int arr[maxn];
int main()
{
	int N;
	int value;
	scanf("%d %d",&N,&value);
	for(int i = 0; i < N; i++) {
		scanf("%d",&arr[i]);
	}
	sort(arr ,arr + N);
	
	int i = 0, j = N - 1;
	int maxlen = N;
	while(i < j) {
		if((float)(arr[j]) / arr[i] > value) {
			if((float)(arr[j - 1]) / arr[i] < (float)arr[j] / arr[i + 1]) 
				j --;
			else 
				i ++;
		} else {
			break;
		}
		maxlen --;
		
	}
	
	printf("%d",maxlen);
}

关于upper_bound 函数的讲解

此题的链接

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值