PKU-1942

先来一道水题开篇

http://poj.org/problem?id=1942


Paths on a Grid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 26997 Accepted: 6784

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

Source



看完第一眼就想到了最笨的办法。

对于m*n的rect, 其中元素rect[x][y],

1. 当x=0时,rect[0][y] = 1;

2. 当y=n时,rect[x][n] = 1;

3. rect[x][y] = rect[x-1][y] + rect[x][y+1];

这样从左下算到右上,把整个map的权值标出来,最右上角rect[m][0]的值就是答案。

时间复杂度 O(m*n), 对于两个int32相乘,时刻准备TLE  - -


正确解法

“一条 m+n 长度的直线,取其中n个单位长度,竖起来共有C(m+n, n)种取法”

只能说全靠李姐能力...唉,题做少了再见


#include <iostream>
using namespace std;


double combin(double a, double b) {
if ( b > a - b) {
b = a - b;
}
double tmp = 1;
for (double i = 0; i < b; ++i) {
tmp *= (a - i) / (b - i);
}
return tmp;
}


int main() {
double m, n;
while (true) {
cin >> m >> n;
if ( m == 0 && n == 0) {
break;
} else if (m == 0 || n == 0) {
printf("1\n");
continue;
}
printf("%.0lf\n", combin(m+n, n));
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值