1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

根据层序遍历判断最大堆,最小堆或者不是堆
数组储存的层序遍历用下标的形式遍历树
如果从1开始,左孩子是2n,右孩子是2n+1;
如果从0开始,左孩子是2n+1,右孩子是2n+2;

#include<bits/stdc++.h>
using namespace std;
void dfs(vector<int>& tree, int root) {
	if (root >= tree.size()) return;
	dfs(tree, 2 * root + 1);
	dfs(tree, 2 * root + 2);
	cout << tree[root]<<(root==0?"":" ");
}
bool check(int root, vector<int>& lorder, int ope, int last) {
	if (root >= lorder.size()) return true;
	if (ope == 1) return lorder[root] < last && check(2 * root + 1, lorder, ope, lorder[root]) && check(2 * root + 2, lorder, ope, lorder[root]);
	else return lorder[root] > last && check(2 * root + 1, lorder, ope, lorder[root]) && check(2 * root + 2, lorder, ope, lorder[root]);
	return false;
}
int main()
{
	int n, m;
	cin >> n >> m;
	for (int i = 0; i < n; i++){
		vector<int>lorder(m),postorder;
		for (int j = 0; j < m; j++)
			cin >> lorder[j];
        bool f=lorder[0] > lorder[1];
		if (check(0, lorder, f, f ? INT_MAX : INT_MIN))
			cout << (f ? "Max Heap" : "Min Heap") << endl;
		else
			cout << "Not Heap" << endl;
		dfs(lorder, 0);
		cout << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值