题目链接:http://poj.org/problem?id=3264
题目:
Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 75803 Accepted: 34741
Case Time Limit: 2000MS
Description
For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N and Q.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
解题思路:
我们设置每个块的长度为k = sqrt(n),然后分块暴力。时间复杂度是:n + n * sqrt(n) + 2 * n + q * sqrt(n), 总的时间复杂度为:(n + q)* sqrt(n);不会超时。
注意点:
1…width = sqrt((double) n);这里一定要强制转换一下,要不然回编译错误!!
AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 50000 + 50;
const int inf = 0x3f3f3f3f;
int a[maxn];
int black_maxx[maxn], black_minn[maxn];
int main(void) {
int n, q;
scanf("%d%d", &n, &q);
for(int i = 0; i < n; i ++) scanf("%d", &a[i]);
int width = sqrt((double)n); //每一个快有k 个元素
memset(black_minn, 0x3f, sizeof black_minn);
for(int i = 0; i < n; i ++) {
int tmp = i / width;
black_maxx[tmp] = max(black_maxx[tmp], a[i]);
black_minn[tmp] = min(black_minn[tmp], a[i]);
}
for(int i = 1, l, r; i <= q; i ++) {
scanf("%d%d", &l, &r);
int tmp1 = (l - 1) / width, tmp2 = (r - 1) / width, ans = 0, ans_minn = inf;
for(int j = l - 1; j < r && (j < (tmp1 + 1) * width); j ++)
ans = max(ans, a[j]), ans_minn = min(ans_minn, a[j]);
for(int j = tmp2 * width; j < r && j >= l - 1; j ++)
ans = max(ans, a[j]), ans_minn = min(ans_minn, a[j]);
for(int j = tmp1 + 1; j < tmp2; j ++)
ans = max(ans, black_maxx[j]), ans_minn = min(ans_minn, black_minn[j]);
printf("%d\n", ans - ans_minn);
}
return 0;
}
总结:分块思想就是将全部的区间分成适当长度的块,然后直接暴力,但是这样的暴力要比一般直接暴力的时间复杂度好一点。