ZJU_1088_Syste Overload

题目链接:http://icpc.njust.edu.cn/Problem/Zju/1088/

System Overload
Time Limit: Java: 10000 ms / Others: 10000 ms

Memory Limit: Java: 32768 KB / Others: 32768 KB

[显示标签]
Description

Recently you must have experienced that when too many people use the BBS
simultaneously, the net becomes very, very slow.

To put an end to this problem, the Sysop has developed a contingency scheme for
times of peak load to cut off net access for some buildings of the university in a systematic, totally
fair manner. Our university buildings were enumerated randomly from 1 to n.
XWB is number 1, CaoGuangBiao (CGB) Building is number 2, and so on in a purely random
order.

Then a number m would be picked at random, and BBS access would first be cut off in
building 1 (clearly the fairest starting point) and then in every mth building after that,
wrapping around to 1 after n, and ignoring buildings already cut off. For example, if n=17 and m=5, net access would be cut off to the buildings in the
order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7].
The problem is that it is clearly fairest to cut off CGB Building last (after all, this is where the
best programmers come from), so for a given n, the random number m needs
to be carefully chosen so that building 2 is the last building selected.

Your job is to write a program that will read in a number of buildings n and then determine
the smallest integer m that will ensure that our CGB Building can surf the net while the rest
of the university is cut off.

Input
The input file will contain one or more lines, each line containing one integer n with
3 <= n
Input is terminated by a value of zero (0) for n.
Output
For each line of the input, print one line containing the integer m fulfilling the
requirement specified above.
Sample Input
3
4
5
6
7
8
9
10
11
12
0
Sample Output
2
5
2
4
3
11
2
3
8
16

题目大意:
给出一个n,然后让我们求出最小的m使得的2个点最后被遍历到。假如当前遍历到了1这个点,那么就往后去遍历到第 1+m 个点,并且中间的点都必须没有遍历到。

解题思路:
由于n的范围不大,所以我是直接从m = 2不断增大去枚举,只有在这个增大的过程中某个m满足的题目要求就直接输出。
模拟的过程:首先让遍历的过程只执行n - 1次,每次过程都是直接让数字增大1,m–,然后判断。最后判断vis[2]是否被遍历过。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int maxn = 200;

bool vis[maxn];

inline bool check(int m, int n) {
	int cnt = 1, fir = 1, tmp = m; vis[1] = true;
	while(cnt < n - 1) {
		while(true) {
			fir ++;
			m --;
			if(fir > n) fir = 1;
			if(vis[fir]) m ++;
			else if(!vis[fir] && !m) {
				vis[fir] = true;
				if(fir == 2) return false;
				break;
			}		
		}
		m = tmp;
		cnt ++;
	}
	if(!vis[2]) return true;
	return false;
}

int main(void) {
//	freopen("in.txt", "r", stdin);
	
	int n;
	while(scanf("%d", &n) != EOF && n) {
		int m = 2;
		memset(vis, false, sizeof vis);
		while(true) {
			if(check(m, n)) {
				printf("%d\n", m);
				break;
			} else m ++;
			memset(vis, false, sizeof vis);
		}
	}
	
//	fclose(stdin);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值