HDU - 4283You Are the One 区间dp

题目链接:

https://vjudge.net/problem/HDU-4283

The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him? 

Input

  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100) 
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100) 

Output

  For each test case, output the least summary of unhappiness . 

Sample Input

2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output

Case #1: 20
Case #2: 24

题解:

       题目看了很长时间才看懂,有n个人,排成一个队列,然后有一个小黑屋,可以看成一个栈,通过栈可以调整他们的顺序,可以看成他们依次进栈出栈,出栈顺序有很多种,然后他们每个人都有一个愤怒值Di,出栈后如果他排在第k名,那么他的愤怒值为Di*(k-1).  问他们愤怒值之和最小是多少。   原题的题意并不是都进栈出栈,有的人路过黑屋子可以直接过去,  直接过去也可以看成是他进栈又出栈了。

      这是一道区间dp题,我们用dp[i][j]表示区间i到j的最小愤怒值之和,先不用考虑这个这个区间前边有多少人。然后想一想状态如何转移,也就是怎么由小区间去推大区间,区间dp都是从小区间推出大区间。

    dp[i][j] 这个区间有k=j-i+1个人,他可能第1个出栈,第2个出栈.....第k个出栈,根据i出栈的位置,得出下列转移方程:

dp[i][j]=min(dp[i][j],dp[i+1][k]+(k-i)*a[i]+dp[k+1][j]+(sum[j]-sum[k])*(k-i+1));    其中 i<=k<=j;sum数组是前缀和

  第i个人出栈后的位置在k ,区间 I+1到k在他前边,共k-i个人,第i个人在第(k-i+1)名,所以第i个人的愤怒值是(k-i)*a[i].

区间k+1到j在他后边,区间合并之后,区间k+1到j前边有(k-i+1)个人,所以再加上dp[k+1[j]+(sum[j]-sum[k])*(k-i+1).

因为求出dp[k+1[j]的时候并没有考虑前边有多少人,现在这个区间前边有(k-i+1)个人,他们每个人的排名都增加了(k-i+1)名,所以每个人都应该再加上(k-i+1)乘他们自己的愤怒值D。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=102;
const int inf=0x3f3f3f3f;
int n,a[maxn],sum[maxn];
int dp[maxn][maxn];
int main(){
    int t;
    cin>>t;
    for(int cas=1;cas<=t;cas++){
        scanf("%d",&n);
        for(int i=1;i<=n;i++) scanf("%d",a+i);
        for(int i=1;i<=n;i++) sum[i]=sum[i-1]+a[i];
        for(int len=1;len<n;len++){
            for(int i=1;i<=n-len;i++){
                int j=i+len;
                dp[i][j]=inf;
                for(int k=i;k<=j;k++){
                    dp[i][j]=min(dp[i][j],dp[i+1][k]+(k-i)*a[i]+dp[k+1][j]+(sum[j]-sum[k])*(k-i+1));
                }
            }
        }
        printf("Case #%d: %d\n",cas,dp[1][n]);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值