表达式计算

理论知识(中缀式如何转换为后缀式):

式子的表示形式;

  一般表达式(前缀表达式)比如  : a+b*c+(d+e)*f

    后缀表达式 :                               abc*+de+f*+

为什么要转换成为后缀表达式?

  后缀式虽然我们看起来极其的麻烦,但是对于计算机来说可以非常高效地运算,计算机处理后缀表达式值时,遇见要处理的数字便压入栈,若遇到运算符时取出栈顶的两个元素,进行运算,得到的结果,再放入栈中,运算完成后栈中存的元素就是最终运算的结果。

题目:

问题 A: 简单计算器

[命题人 : 外部导入]

时间限制 : 1.000 sec  内存限制 : 32 MB

解决: 959提交: 959统计

题目描述

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

输入

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

输出

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

样例输入 Copy

30 / 90 - 26 + 97 - 5 - 6 - 13 / 88 * 6 + 51 / 29 + 79 * 87 + 57 * 92
0

样例输出 Copy

12178.21

 

#include<iostream>
#include<cstdio>
#include<string>
#include<stack>
#include<queue>
#include<map>
using namespace std;

struct node {
	double num;//操作数
	char op;// 操作数
	bool flag;//true表示操作数,false表示操作符
};

string str;
stack<node> s;//操作符栈
queue<node> q;//后缀式表达式序列
map<char, int> op;     

void change() {//将中缀式表达式转换为后缀式表达式
	double num;
	node temp;
	for (int i = 0; i < str.length();) {
		if (str[i] >= '0' && str[i] <= '9') {
			temp.flag = true;//标记是数字
			temp.num = str[i++] - '0';
			while (i < str.length() && str[i] >= '0' && str[i] <= '9') {
				temp.num = temp.num * 10 + (str[i] - '0');//更新这个操作数
				i++;
			}
			q.push(temp);//将这个操作数压入后缀式表达式的队列
		}
		else {
			temp.flag = false;
			//只要操作符栈的栈顶元素比该操作符优先级高
			//就把操作符栈栈顶元素弹出到后缀式表达式的队列
			while (!s.empty() && op[str[i]] <= op[s.top().op]) {
				q.push(s.top());
				s.pop();
			}
			temp.op = str[i];
			s.push(temp);//把该操作符压入操作符栈中
			i++;
		}
	}
	//如果操作符栈中还有操作符,就把它弹到后缀表达队列中
	while (!s.empty()) {
		q.push(s.top());
		s.pop();
	}
}
double Count() {//计算后缀表达式
	double temp1, temp2;
	node cur, temp;
	while (!q.empty()) {
		cur = q.front();//记录队首元素
		q.pop();
		if (cur.flag == true) s.push(cur);//如果是操作数,直接压入栈
		else {
			temp2 = s.top().num;//弹出第二个操作数
			s.pop();
			temp1 = s.top().num;//弹出第一个操作数
			s.pop();
			temp.flag = true;//临时记录操作数
			if (cur.op == '+') temp.num = temp1 + temp2;
			else if (cur.op == '-') temp.num = temp1 - temp2;
			else if (cur.op == '*') temp.num = temp1 * temp2;
			else if (cur.op == '/') temp.num = temp1 / temp2;
			s.push(temp);

		}
	}
	return s.top().num;//栈顶元素就是后缀式的值
}
int main()
{
	op['+'] = op['-'] = 1;
	op['*'] = op['/'] = 2;
	while (getline(cin, str), str != "0")
	{
		for (string::iterator it = str.end(); it != str.begin(); it--) {
			if (*it == ' ') str.erase(it);//删除表达式中的空格
		}
		while (!s.empty()) s.pop();
		change();
		printf("%.2f\n", Count());//计算后缀表达式
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值