素数环

A ring is composed of n (even number) circles as shown in diagram. Put natural numbers 1, 2, . . . , n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n ≤ 16)
Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.

You are to write a program that completes above process.

Sample Input

6 8

Sample Output

Case 1:

1 4 3 2 5 6

1 6 5 2 3 4

Case 2:

1 2 3 8 5 6 7 4

1 2 5 8 3 4 7 6

1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

#include <iostream>
#include  <cstring>
using namespace std;
int a[20],n;
int c=1;
bool b[20];
int pz(int x){
	int i;
	for( i=2;i<=x/2;i++)
	if(x%i==0)return 0;
	if(i>x/2)return 1;
	if(x==1)return 0;
}
void dfs(int step){	
	if(step==n+1&&pz(a[1]+a[step-1])){
		cout<<a[1]<<' ';
		for(int i=2;i<=n;i++)
		{	
			if(i==n)cout<<a[i];
			else cout<<a[i]<<' ';
		}
		cout<<'\n';
	}
	for(int i=2;i<=n;i++){
		if(b[i]==false&&pz(a[step-1]+i)){
			a[step]=i;
			b[i]=true;
			dfs(step+1);
			b[i]=false;
		}
	}	
}
int main(int argc, char *argv[])
{			//freopen("r.txt","r",stdin);
			//freopen("w.txt","w",stdout);
		while(cin>>n){			
		a[1]=1;
		memset(b,sizeof(b),false);
		if(c>1)cout<<'\n';
		cout<<"Case "<<c++<<':'<<'\n';
		dfs(2);	
		
		}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值