1142 Maximal Clique (25 分)——PAT A

25 篇文章 0 订阅

1142 Maximal Clique (25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

【分析】无向图,判断子图是否最大完全图

总结:

坚持就是胜利,崩溃到完成只差一步。

#include <iostream>
#include <cstdio>
#include <vector>
#include <string.h>
using namespace std;
const int maxn = 2e2 + 5;
int G[maxn][maxn];
int n, m, M, k;
int v[maxn];
bool used[maxn];
void solve() {
	fill(used, used + maxn, false);
	for (int i = 0; i < k; i++) {
		for (int j = 0; j < k; j++) {
			if (j == i) continue;
			if (G[v[i]][v[j]] == 0) {
				printf("Not a Clique");
				return;
			}
			used[v[i]] = true;
			used[v[j]] = true;
		}
	}
	for (int i = 1; i <= n; i++) {
		if (used[i]) continue;
		for (int j = 0; j < k; j++) {
			if (G[i][v[j]] == 0) break;
			if (G[i][v[j]] == 1 && j == k - 1) {
				printf("Not Maximal");
				return;
			}
		}
	}
	printf("Yes");
}
int main() {
	cin >> n >> m;
	memset(G, 0, sizeof(G));
	for (int i = 0; i < m; i++) {
		int u, v;
		cin >> u >> v;
		G[u][v] = 1;
		G[v][u] = 1;
	}
	cin >> M;
	for (int i = 0; i < M; i++) {
		cin >> k;
		for (int j = 0; j < k; j++) scanf("%d", &v[j]);
		solve();
		if (i != M - 1) printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值