1185:单词排序
时间限制: 1000 ms 内存限制: 65536 KB
提交数: 7688 通过数: 3919
【题目描述】
输入一行单词序列,相邻单词之间由1个或多个空格间隔,请按照字典序输出这些单词,要求重复的单词只输出一次。(区分大小写)
【输入】
一行单词序列,最少1个单词,最多100个单词,每个单词长度不超过50,单词之间用至少1个空格间隔。数据不含除字母、空格外的其他字符。
【输出】
按字典序输出这些单词,重复的单词只输出一次。
【输入样例】
She wants to go to Peking University to study Chinese
【输出样例】
Chinese Peking She University go study to wants
解释: 输入时候要注意用
while(cin>>a[i])
#include<bits/stdc++.h>
using namespace std;
string a[105];
bool cmp(string x,string y){
return x<y;
}
int main(){
freopen("test.in","r",stdin);
freopen("test.out","w",stdout);
int k = 1;
while(cin>>a[k]){
k++;
}
k--;
for(int i=1;i<=k;i++){
for(int j=1;j<=k-i;j++){
if(!cmp(a[j],a[j+1])){
swap(a[j],a[j+1]);
}
}
}
for(int i=1;i<=k;i++){
if(a[i]!=a[i-1]){
cout<<a[i]<<endl;
}
}
return 0;
}