HDU OJ -1001 Sum Problem

Sum Problem

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1
100

Sample Output

1

5050

题目大意

实现从1到n的整数求和。
要注意空格的输出。
每个答案输出之后都要有一个空行。

分析

这是杭电Online Exercise的第二题。
最开始当然是常规想法,循环相加嘛。

# include <iostream>
using namespace std;

int main()
{
    int n;
    while (cin >> n)
    {
        int sum = 0;
        for (int i = 1; i <= n; i++)
        {
            sum = sum + i;
        }
        cout << sum << endl << endl;//注意空行
    }
    return 0;
}

当然在没有时间长度的限制和测试数据不太大的时候可以这么做,毕竟电脑这种东西搞这种运算很简单。
但是,最好在编程时,用尽可能快的、复杂度低的方法来实现。

# include <iostream>
using namespace std;

int main()
{
    long long int n;
    while (cin >> n)
    {
        int sum = 0;
        sum = (1 + n)*n / 2;
        cout << sum << endl << endl;
    }
    return 0;
}

用一个求和公式就好了,如果测试数据或者时间上有要求的话,第一个就很可能Wrong了。
注意数据范围吧,这里其实不用long long int,int就可以。

总结

简单入门题,注意空行、换行细节,实现方法尽量简单、快速。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值