数据结构实验之二叉树的建立与遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

Input
输入一个长度小于50个字符的字符串。
Output
输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
Sample Input
abc,,de,g,,f,,,

Sample Output
cbegdfa
cgefdba
3
5

代码如下:
//#include<stdio.h>
//#include<stdlib.h>
//#include<string.h>
//或者直接用这个C++的头文件就好,囊括所有,啊哈哈!!!
#include<bits/stdc++.h>
using namespace std;
char s[55];
int i,cnt;//计数的呀,
typedef struct node
{
    char data;
    struct node *l,*r;
}tree;
tree *creat()
{
    tree *root;
    char c = s[i++];
    if(c==',')
        return NULL;//或者root=NULL;
    else
    {
        root = new tree;
        root->data=c;
        root->l=creat();
        root->r=creat();
    }
    return root;
}
void zhongxu(tree *root)//或者inorder,,中序序列输出啊,不想多讲咦,一看就会
{
    if(root)
    {
        zhongxu(root->l);
        printf("%c",root->data);
        zhongxu(root->r);
    }
}
void houxu(tree *root)//或者postorder ,后序序列输出,
{
    if(root)
    {
        houxu(root->l);
        houxu(root->r);
        printf("%c",root->data);
    }
}
// cnt=0; 可以在这里写,也可以在主函数的循环中写,写在这里,不容易忘记,习惯写在主函数中。
void leafcount(tree *root)
{
    if(root)// 和上面一样,这句话是判断当前节点是否为空,可以扩写为!=NULL;
    {
        if(root->l==NULL&&root->r==NULL)
            cnt++;
            leafcount(root->l);
            leafcount(root->r);
            //这是基于前序的思想写的计算叶子节点,当然,第二个if循环也可以
            //放在两个leafcount的中间和后面位置,基于中序和后序的想法楼。

    }
}
int PostTreeDepth(tree *root)
{
    /*int hl,hr,max;
    if(root!=NULL)
    {
        hl=PostTreeDepth(root->l);
        hr=PostTreeDepth(root->r);
        max = hl > hr ? hl : hr;
        return max + 1;
    }
    else
        return 0;*/ //当然我们可以用上面这个咦,不过尝试新的代码。
    int hl,hr;
    if(!root)//这句话!什么玩意经常出现在站和队列中,表示为空,
        return 0;
    else
    {
        hl=PostTreeDepth(root->l);
        hr=PostTreeDepth(root->r);
        return  hl>=hr?hl+1:hr+1;
    }

}
int main()
{
    while(~scanf("%s",s))
    {
        cnt=0;
        i=0;
        tree *root;
        root = new tree;
        root = creat();
        zhongxu(root);
        printf("\n");//C++中为 cout<<endl;
        houxu(root);
        printf("\n");
        leafcount(root);
        printf("%d\n",cnt);
        printf("%d\n",PostTreeDepth(root));
    }
        return 0;
}


提交用c++提交,不然会出现 compile error。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值