Silver Cow Party(最短路)

Silver Cow Party(最短路)

Time limit:2000 ms
Memory limit:65536 kB
OS:Linux
judge:https://vjudge.net/contest/297882#problem/D

描述

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

题意

来自n个农场(1≤n≤1000)的1.n头奶牛将参加农场x(1≤x≤n)举办的大型奶牛派对。共有m(1≤m≤100000)单向(单向道路连接两个农场;一号公路需要Ti(1≤Ti≤100)单位的穿越时间。

每头牛都必须走到派对上,派对结束后,回到她的农场。每头母牛都懒惰,因此选择了一条时间最短的最佳路线。一头牛的返回路线可能不同于她最初去派对的路线,因为道路是单向的。

在所有的奶牛中,一头奶牛必须花多长时间步行去聚会和回来?

输入

第1行:三个空格分隔的整数,分别为:n、m和x

第2行…M+1:第I+1行用三个空格分隔的整数(ai、bi和ti)描述了道路I。所描述的道路从农场ai到农场bi,需要时间单位进行穿越。

输出

第1行:一个整数:任何一头牛必须行走的最长时间。

提示

奶牛4直接进入一方(3个单位),通过农场1和3(7个单位)返回,总共10个时间单位。

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

代码

#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i <= (b); i++)
#define maxn 1005
#define inf 0x3f3f3f3f
using namespace std;
struct poi {
	int v, w;
	poi() {}
	poi(int v, int w) :v(v), w(w) {}
	bool operator < (const poi tem) const {
		return w < tem.w;
	}
};
int n, m, x;
int dis[maxn];
bool vis[maxn];
vector<poi> mp[maxn];
int SPFA(int S, int T) {
	priority_queue<int> que;
	_for(i, maxn) dis[i] = inf;
	memset(vis, 0, sizeof(vis));
	dis[S] = 0;
	vis[S] = 1;
	que.push(S);
	while (que.size()) {
		int tem = que.top();
		que.pop();
		vis[tem] = 0;
		_for(i, mp[tem].size()) {
			if (dis[mp[tem][i].v] > dis[tem] + mp[tem][i].w) {
				dis[mp[tem][i].v] = dis[tem] + mp[tem][i].w;
				if (!vis[mp[tem][i].v]) {
					que.push(mp[tem][i].v);
					vis[mp[tem][i].v] = 1;
				}
			}
		}
	}
	return dis[T];
}
int main() {
	//freopen("in.txt", "r", stdin);

	scanf("%d%d%d", &n, &m, &x);
	_for(i, m) {
		int a, b, c;
		scanf("%d%d%d", &a, &b, &c);
		mp[a].push_back(poi(b, c));
	}
	int ans = -1;
	_rep(i, 1, n) {
		if (i == x) continue;
		ans = max(ans, SPFA(i, x) + SPFA(x, i));
	}
	printf("%d\n", ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值