Treasure Exploration(二分图匹配+Floyd最短路)

Treasure Exploration(二分图匹配-匈牙利算法+最短路-Floyd算法)

描述

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N N N points (these N N N points are numbered from 1 1 1 to N N N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

输入

The input will consist of several test cases. For each test case, two integers N ( 1 &lt; = N &lt; = 500 ) N (1 &lt;= N &lt;= 500) N(1<=N<=500) and M ( 0 &lt; = M &lt; = 5000 ) M (0 &lt;= M &lt;= 5000) M(0<=M<=5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A A A to B ( 0 &lt; A , B &lt; = N ) B (0 &lt; A, B &lt;= N) B(0<A,B<=N). The input is terminated by a single line with two zeros.

输出

For each test of the input, print a line containing the least robots needed.

题意

用最少的线覆盖整个区域,但是“线”可以交叉,但不能重叠,也就是说点可以重复使用,例如:在这里插入图片描述
构造匹配:1-2;2-3后还可以继续构造4-2;2-5
在这里插入图片描述
解决方案就是利用最短路的原理进行“缩点”。处理完后进行匈牙利算法匹配即可

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

代码

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <cstdio>
#include <string.h>
#include <string>
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i <= (b); i++)
#define maxn 1505
#define inf 0x3f3f3f3f
using namespace std;
//vector<int> G[maxn];
int f[maxn], used[maxn];
int n;
int p[maxn][maxn];
bool dfs(int u) {
	_for(i, n) {
		if (!used[i] && p[u][i]) {
			used[i] = 1;
			if (f[i] == -1 || dfs(f[i])) {
				f[i] = u;
				return 1;
			}
		}
	}
	return 0;
}
int Maxmatch() {
	int ans = 0;
	memset(f, -1, sizeof(f));
	_for(i, n) {
		memset(used, 0, sizeof(used));
		if (dfs(i)) {
			ans++;
		}
	}
	return ans;
}
void Floyd() {
	_for(k, n) {
		_for(i, n) {
			_for(j, n) {
				if (p[i][k] && p[k][j]) {
					p[i][j] = 1;
				}
			}
		}
	}
}
int main() {
	int m;
	while (cin >> n >> m, n) {
		memset(p, 0, sizeof(p));
		_for(i, m) {
			int u, v;
			cin >> u >> v;
			u--; v--;
			p[u][v] = 1;
		}
		Floyd();
		cout << n - Maxmatch() << "\n";
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值