Cat VS Dog(二分图匹配)

Cat VS Dog(二分图匹配)

描述

The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child’s like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child’s like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N &lt; = 100 , M &lt; = 100 N &lt;= 100, M &lt;= 100 N<=100,M<=100 and P &lt; = 500 P &lt;= 500 P<=500.
Next P P P lines, each line contains a child’s like-animal and dislike-animal, C C C for cat and D D D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3

思路

一群小孩,有的喜欢猫不喜欢狗,而有的喜欢狗不喜欢猫。现在动物园要移走一些猫和狗,如何分配才能使尽可能多的小孩保持开心。
由于不同的小孩可以喜欢同一只猫或狗,所以按猫狗分组显然是不行的,转换一下思维,如果按小孩分组,把两个喜好有矛盾的小孩连线来进行最大匹配,那么最大匹配的一半就是最后不开心的小孩,最后拿总人数减去最大匹配的一半就是结果了。

Hint

Case 2: Remove D 1 D1 D1 and D 2 D2 D2, that makes child 1 , 2 , 3 1, 2, 3 1,2,3 happy.

代码

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <cstdio>
#include <string.h>
#include <string>
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i <= (b); i++)
#define maxn 1505
#define inf 0x3f3f3f3f
using namespace std;
int c;
int p[maxn][maxn];
char a[maxn][5], b[maxn][5];
int used[maxn];
int f[maxn];
bool dfs(int u) {
	_for(i, c) {
		if (!used[i] && p[u][i]) {
			used[i] = 1;
			if (f[i] == -1 || dfs(f[i])) {
				f[i] = u;
				return 1;
			}
		}
	}
	return 0;
}
int Maxmatch() {
	int ans = 0;
	memset(f, -1, sizeof(f));
	_for(i, c) {
		memset(used, 0, sizeof(used));
		ans += dfs(i);
	}
	return ans;
}
int main() {
	int m, n;
	while (cin >> n >> m >> c) {
		memset(p, 0, sizeof(p));
		_for(i, c) {
			cin >> a[i] >> b[i];
		}
		_for(i, c) {
			_for(j, i) {
				if (strcmp(a[i], b[j]) == 0 || 
					strcmp(a[j], b[i]) == 0) {
					p[i][j] = p[j][i] = 1;
				}
			}
		}
		cout << c - Maxmatch() / 2 << "\n";
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值