Compromise(LCS最长公共子序列+记录路径)

Compromise(LCS最长公共子序列+记录路径)

source:POJ 2250
Time limit:1000 ms
Memory limit:65536 kB
Special judge:Yes
OS:Linux

描述

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,…) that it is really hard to choose what to do.

Therefore the German government requires a program for the following task:
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases.
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single ‘#’.
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden

题意

给出两个字符串,以单词为单位进行比较,找出两个字符串的最长公共子序列,并输出。

dp递推时记录路径,推完深搜一波回归时输出单词即可。

代码
#include <iostream>
#include <algorithm>
#include <string.h>
#include <map>
#include <string>
#define maxn 105
#define inf 0x3f3f3f3f
#define ll long long
#define _for(i, a) for(ll i = 0; i < (a); i++)
#define _rep(i, a, b) for(ll i = (a); i <= (b); i++)
using namespace std;
int dp[maxn][maxn];
int an, bn;
string a[maxn], b[maxn];
int pos[maxn][maxn];//记录路径
void outp(int x, int y) {
	if (pos[x][y] == 1) {
		outp(x - 1, y - 1);
		if (x != an && y != bn) {
			cout << a[x - 1] << ' ';
		}
		else {
			cout << a[x - 1] << "\n";
		}
	}
	if (pos[x][y] == 2) {
		outp(x - 1, y);
	}
	if (pos[x][y] == 3) {
		outp(x, y - 1);
	}
}
int main() {
	while (cin >> a[0]) {
		memset(dp, 0, sizeof(dp));
		memset(pos, 0, sizeof(pos));
		for (an = 1; cin >> a[an], a[an] != "#"; an++);
		for (bn = 0; cin >> b[bn], b[bn] != "#"; bn++);
		_rep(i, 1, an) {
			_rep(j, 1, bn) {
				if (a[i - 1] == b[j - 1]) {
					dp[i][j] = dp[i - 1][j - 1] + 1;
					pos[i][j] = 1;
				}
				else if (dp[i - 1][j] > dp[i][j - 1]) {
					dp[i][j] = dp[i - 1][j];
					pos[i][j] = 2;
				}
				else {
					dp[i][j] = dp[i][j - 1];
					pos[i][j] = 3;
				}
			}
		}
		outp(an, bn);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值