Atcoder Context 130F-Minimum Bounding Box【三分查找】 难度:**

There are N points in a two-dimensional plane. The initial coordinates of the i-th point are (xi,yi). Now, each point starts moving at a speed of 1 per second, in a direction parallel to the x- or y- axis. You are given a character di that represents the specific direction in which the i-th point moves, as follows:

If di= R, the i-th point moves in the positive x direction;
If di= L, the i-th point moves in the negative x direction;
If di= U, the i-th point moves in the positive y direction;
If di= D, the i-th point moves in the negative y direction.
You can stop all the points at some moment of your choice after they start moving (including the moment they start moving). Then, let xmax and xmin be the maximum and minimum among the x-coordinates of the N points, respectively. Similarly, let ymax and ymin be the maximum and minimum among the y-coordinates of the N points, respectively.

Find the minimum possible value of (xmax−xmin)×(ymax−ymin) and print it.

Constraints
1≤N≤105
−108≤xi, yi≤108
xi and yi are integers.
di is R, L, U, or D.
Input
Input is given from Standard Input in the following format:

N
x1 y1 d1
x2 y2 d2
.
.
.
xN yN dN
Output
Print the minimum possible value of (xmax−xmin)×(ymax−ymin).

The output will be considered correct when its absolute or relative error from the judge’s output is at most 10−9.

Sample Input 1
Copy
2
0 3 D
3 0 L
Sample Output 1
Copy
0
After three seconds, the two points will meet at the origin. The value in question will be 0 at that moment.

Sample Input 2
Copy
5
-7 -10 U
7 -6 U
-8 7 D
-3 3 D
0 -6 R
Sample Output 2
Copy
97.5
The answer may not be an integer.

Sample Input 3
Copy
20
6 -10 R
-4 -9 U
9 6 D
-3 -2 R
0 7 D
4 5 D
10 -10 U
-1 -8 U
10 -6 D
8 -5 U
6 4 D
0 3 D
7 9 R
9 -4 R
3 10 D
1 9 U
1 -6 U
9 -8 R
6 7 D
7 -3 D
Sample Output 3
Copy
273

题解:

面积的极小值只有一个,用三分查找即可

代码:

#include<stdio.h>
#include<math.h>
#define N 100000000
#define M 100005
int main()
{
	int n;
	double x[M],y[M];
	char c[M];
	double minS=-1,S1,S2,l=0,r=N;
	double minl1=N,maxr1=-N,maxu1=-N,mind1=N,xx1,yy1,move1=0;
	double minl2=N,maxr2=-N,maxu2=-N,mind2=N,xx2,yy2,move2=N;
    scanf("%d",&n);
    for(int i=0;i<n;i++)scanf("%lf%lf %c",&x[i],&y[i],&c[i]);
    for(int k=0;k<=10000&&(move2-move1>0.00000000001);k++)
	{
		minl1=N,maxr1=-N,maxu1=-N,mind1=N;
		minl2=N,maxr2=-N,maxu2=-N,mind2=N;
        move1=(r/3+2*l/3),move2=(2*r/3+l/3);
        for(int i=0;i<n;i++)
		{
	        xx1=xx2=x[i];
			yy1=yy2=y[i];
			if(c[i]=='U')
			{
				yy1+=move1;
				yy2+=move2;
			}
			if(c[i]=='D')
			{
				yy1-=move1;
				yy2-=move2;
			}
			if(c[i]=='L')
			{
				xx1-=move1;
				xx2-=move2;
			}
			if(c[i]=='R')
			{
				xx1+=move1;
				xx2+=move2;
			}
	        if(xx1<minl1)minl1=xx1;
	        if(xx1>maxr1)maxr1=xx1;
	        if(yy1<mind1)mind1=yy1;
	        if(yy1>maxu1)maxu1=yy1;
	        if(xx2<minl2)minl2=xx2;
	        if(xx2>maxr2)maxr2=xx2;
	        if(yy2<mind2)mind2=yy2;
	        if(yy2>maxu2)maxu2=yy2;
	    }
	    S1=(maxr1-minl1)*(maxu1-mind1);
	    S2=(maxr2-minl2)*(maxu2-mind2);
        if(S1<minS||minS==-1)minS=S1;
        if(S2<minS||minS==-1)minS=S2;
        if(S1>S2)l=move1;
        else r=move2;
    }
    printf("%.10f\n",minS);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值