反Nim游戏

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.
Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.
Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.
Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747
Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.
Sample Input
2
3
3 5 1
1
1
Sample Output
John
Brother

分析:
先手必胜当且仅当:
1.每堆石子的个数为1,且异或值为0,也就是偶数堆,所以后手最后取,所以后手必败。
2.有一堆石子个数大于1,且异或值不等于0,也就有先手可以把大于1的那一堆直接拿走或者是将其变为1,使得取完之后异或值不为0.所以先手胜
3.如果有多堆大于1的,不管它取得是等于1的石子堆,还是不等于1的,都能将其转换为(2)条件,或者是后手遇到(2)这种情况,所以(1)、(2)是当且仅当的条件。

#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;
int N;
int color[50];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&N);
        int sum=0;
        int Pile=0;
        for(int i=0;i<N;i++){
            scanf("%d",&color[i]);
            if(color[i]>1)Pile++;
            sum^=color[i];
        }
        if((Pile>=1&&sum!=0)||(Pile==0&&sum==0))printf("John\n");
        else printf("Brother\n");
        }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值