1131 Subway Map (30分)-DFS,最短路径(待更新)

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

subwaymap.jpg

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 100), the number of subway lines. Then N lines follow, with the i-th (i=1,⋯,N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (≤ 100) is the number of stops, and S[i]'s (i=1,⋯,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i] and S[i+1] (i=1,⋯,M−1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (≤ 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

samplemap.jpg

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

解题思路:

  1. 最短路径问题,由于每个站点为四位整数,不能直接采用邻接矩阵,故采用链表的方法,通过容器map来实现,关键字为站点编号,元素为vector队列,为与该站点直接连接的站点。
  2. 采用DFS的思路,遍历图元素,当到达终点或者当前路径大于最短路径长度时,返回。若能到达终点,说明该路径长度不大于最短路径长度,如果相等,则取换乘次数最少的路径;如果不相等,则将最短路径更新为该路径。
  3. 知识点:如果快速表示两个字符串之前的关系?可通过map实现,将两个字符串以两种顺序拼接在一起,作为map的关键字,元素里面在存放表示这两者之前的关系。如本题,将两个站点信息拼接在一起,再在容器对应位置存放路线编号,即可实现路线信息的存储。

(代码未能AC,同时发现题目存在一些小问题,比如在路径站点数相同的情况下,应选择换乘次数最少的路线,题目保证这是唯一的,但是样例中的第二个查询点存在两条路径站点数相同、换乘次数也相同的路线,路线6666 8432 4011 1306 3001 3013 3812 3011 3010 2302 2001 和路线6666 8432 4011 1306 3003 2333 3066 3212 3008 2302 2001 ,所以题目表述存在问题,AC代码可以参考1131 Subway Map (30 分)

代码如下:

#include <iostream>
#include <map>
#include <vector> 
using namespace std;
#define INF 0x7fffffff
vector<int> path;
map<int,int> line;
map<int ,vector<int> >node;
int mincnt=INF,mintransfer=INF,visist[10000];
void DFS(int start,int end,int cnt,vector<int> newpath);
int transfercnt(vector<int> a);
int main(){
	int N,M,start,end,i;
	cin>>N;
	for(i=0;i<N;i++){
		scanf("%d",&M);
		int pre,temp;
		scanf("%d",&pre);
		while(--M){
			scanf("%d",&temp);
			node[pre].push_back(temp);
			node[temp].push_back(pre);
			line[pre*10000+temp]=line[temp*10000+pre]=i+1;
			pre=temp;
		}	
	}
	int K;
	cin>>K;
	for(i=0;i<10000;i++)
		visist[i]=0;
	while(K--){
		vector<int> newpath;
		scanf("%d%d",&start,&end);
		mincnt=INF;
		mintransfer=INF;	
		DFS(start,end,0,newpath);
		printf("%d\n",mincnt);
		int last=start;
		int j;
		for(j=1;j<path.size()-1;j++){
			if(line[path[j-1]*10000+path[j]]!=line[path[j]*10000+path[j+1]]){
				printf("Take Line#%d from %d to %d.\n",line[path[j-1]*10000+path[j]],last,path[j]);
				last=path[j];	
			}
		}
		printf("Take Line#%d from %d to %d.\n",line[path[j-1]*10000+end],last,end);	
	}
	return 0;
}
void DFS(int start,int end,int cnt,vector<int> newpath){
	int i;
	newpath.push_back(start);
	if(start!=end&&cnt+1<=mincnt){
		visist[start]=1;
		cnt++;
		for(i=0;i<node[start].size();i++){
			if(!visist[node[start][i]])
		 		DFS(node[start][i],end,cnt,newpath);
		}
		visist[start]=0;		
	}
	else if(start==end){
		if(cnt<mincnt||cnt==mincnt&&(transfercnt(newpath)<mintransfer)){
			mincnt=cnt;
			mintransfer=transfercnt(newpath);
			path=newpath;	
		}	
	}	
}
int transfercnt(vector<int> a){
	int i,cnt=0;
	for(i=1;i<a.size()-1;i++){
		if(line[a[i-1]*10000+a[i]]!=line[a[i]*10000+a[i+1]])
			cnt++;
	//	cout<<a[i]<<" ";	
		}
//	cout<<"transfetcnt="<<cnt<<endl;
	return cnt;		
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
地铁线路最短路径可以使用Dijkstra算法来解决。以下是Java实现的示例代码: ```java import java.util.*; public class Subway { private static final int INF = Integer.MAX_VALUE; // 代表正无穷 private int[][] graph; // 地铁图的邻接矩阵表示 private int[] dist; // 起点到各个站点的最短距离 private boolean[] visited; // 标记站点是否已经访问过 private int start; // 起点站 public Subway(int[][] graph, int start) { this.graph = graph; this.start = start; this.dist = new int[graph.length]; this.visited = new boolean[graph.length]; } public void shortestPath() { Arrays.fill(dist, INF); dist[start] = 0; for (int i = 0; i < graph.length; i++) { // 找到未访问过的距离起点最近的站点 int u = -1; int minDist = INF; for (int j = 0; j < graph.length; j++) { if (!visited[j] && dist[j] < minDist) { u = j; minDist = dist[j]; } } if (u == -1) break; // 如果找不到未访问过的站点,则退出循环 visited[u] = true; // 更新与u相邻的站点到起点的最短距离 for (int v = 0; v < graph.length; v++) { if (!visited[v] && graph[u][v] != INF) { dist[v] = Math.min(dist[v], dist[u] + graph[u][v]); } } } } public int getShortestDist(int end) { return dist[end]; } public static void main(String[] args) { int[][] graph = new int[][]{ {0, 3, 1, 2, INF}, {3, 0, INF, INF, 4}, {1, INF, 0, INF, INF}, {2, INF, INF, 0, 5}, {INF, 4, INF, 5, 0} }; Subway subway = new Subway(graph, 0); subway.shortestPath(); System.out.println(subway.getShortestDist(4)); // 输出起点到终点的最短距离 } } ``` 在这个示例代码中,我们用邻接矩阵表示地铁图,用Dijkstra算法求出起点到各个站点的最短距离。可以通过调用`getShortestDist`方法来获取起点到某个站点的最短距离。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值