1034 Head of a Gang (30分)-图的连通集,DFS,STL

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

解题思路:

题目大概意思是给出一系列的通话记录,每一条记录可以看做边,权重为通话时长。要求统计图中每一个连通集内部的结点数,通话时长总数,若总时长超过给定的下限,则输出通话时长最大的成员姓名(即帮派首领),并输出帮派的人数。

  1. 由于结点信息为字符串,为了方便表示,通过map容器将字符串映射为编号;
  2. 利用DFS统计各个连通集内部的总通话时长,人数、通话时长最大的人;
  3. 若连通集返回结果满足要求,则将首领名字和对应的帮派成员数存储在map容器(自动字典序排序)中,最后输出。

AC代码:

#include <iostream>
#include <map>
using namespace std;
#define Max 2001
map<string,int> m1,mp;//名字到编号,首领人数; 
map<int,string> m2;//编号到名字 
int visist[Max],nw[Max],lw[Max][Max];
int cnt=0,head,numbercnt,sum;//总人数、头目编号、帮派人数、 通话总计 
int DFS(int root){
	visist[root]=1;
	sum+=nw[root];
	numbercnt++;
	if(nw[root]>nw[head])
		head=root;
	int i;
	for(i=0;i<cnt;i++){
		if(lw[root][i]&&!visist[i])
			DFS(i);	
	}
	return 0;
}
int main(){
	int n,k;
	cin>>n>>k;
	int i,j;
	for(i=0;i<Max;i++){
		visist[i]=0;
		for(j=0;j<Max;j++)
			lw[i][j]=0;	
	}	
	while(n--){
		char a[4],b[4];
		int w; 
		scanf("%s %s %d",a,b,&w);
		int x,y; 
		if(m1.find(a)==m1.end()){
			m1[a]=cnt;
			m2[cnt]=a;
			x=cnt;
			cnt++;	
		}
		else
			x=m1[a];
		if(m1.find(b)==m1.end()){
			m1[b]=cnt;
			m2[cnt]=b;
			y=cnt;
			cnt++;	
		}
		else
			y=m1[b];
		nw[x]+=w;
		nw[y]+=w;
		lw[x][y]=w;
		lw[y][x]=w;	
	}
	for(i=0;i<cnt;i++){
		if(!visist[i]){
			head=i;
			numbercnt=0;
			sum=0;
			DFS(i);
			if(numbercnt>2&&sum>2*k)
				mp[m2[head]]=numbercnt;	
		}		
	}
	map<string,int>::iterator t;
	cout<<mp.size()<<endl;
	for(t=mp.begin();t!=mp.end();t++)
		printf("%s %d\n",t->first.c_str(),t->second);
		return 0;	
} 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值