【JAVA】(vip)蓝桥杯试题 基础练习 报时助手 BASIC-26 JAVA

试题 基础练习 报时助手

资源限制
时间限制:1.0s 内存限制:512.0MB

问题描述
  给定当前的时间,请用英文的读法将它读出来。
  时间用时h和分m表示,在英文的读法中,读一个时间的方法是:
  如果m为0,则将时读出来,然后加上“o’clock”,如3:00读作“three o’clock”。
  如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。
  时和分的读法使用的是英文数字的读法,其中0~20读作:
  0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。
  30读作thirty,40读作forty,50读作fifty。
  对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。
  按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。

输入格式
  输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。

输出格式
  输出时间时刻的英文。

样例输入
0 15

样例输出
zero fifteen

要点

题目给出的关键字是字符串和条件判断,本题没难点
在这里插入图片描述

代码

import java.util.Scanner;

public class TimeReportingAssistant {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        // 输入包含两个非负整数h和m,表示时间的时和分。
        // 非零的数字前没有前导0。h小于24,m小于60。
        int h = sc.nextInt();
        int m = sc.nextInt();
        sc.close();

        if (m == 0) {
            System.out.println(English(h) + " " + "o'clock");
        } else {
            System.out.println(English(h) + " " + English(m));
        }
    }

    public static String English(int x) {
        String[] strArray = {"zero", "one", "two", "three", "four", "five",
                "six", "seven", "eight", "nine", "ten", "eleven", "twelve", "thirteen",
                "fourteen", "fifteen", "sixteen", "seventeen", "eighteen", "nineteen", "twenty"};
        String x1;
        if (x <= 20) {
            x1 = strArray[x];
        } else if (x < 30) {
            x1 = "twenty" + " " + strArray[x % 20];
        } else if (x == 30) {
            x1 = "thirty";
        } else if (x < 40) {
            x1 = "thirty" + " " + strArray[x % 30];
        } else if (x == 40) {
            x1 = "forty";
        } else if (x < 50) {
            x1 = "forty" + " " + strArray[x % 40];
        } else if (x == 50) {
            x1 = "thirty";
        } else {
            x1 = "fifty" + " " + strArray[x % 50];
        }

        return x1;
    }
}
  • 15
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 23
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 23
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

爱做梦的鱼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值