acwing-3302.表达式求值(中缀)

题目描述
给定一个表达式,其中运算符仅包含 + , - , * , /(加 减 乘 整除),可能包含括号,请你求出表达式的最终值。
输入格式
共一行,为给定表达式。
输出格式
共一行,为表达式的结果。
数据范围
表达式的长度不超过 105。
输入样例
(2+2)*(1+1)
输出样例
8
代码实现

#include<bits/stdc++.h>
using namespace std;
stack<int> num;
stack<char> op;
void eval(){
    int b = num.top(); num.pop();
    int a = num.top(); num.pop();
    
    char p = op.top(); op.pop();
    
    if(p == '+') num.push(a+b);
    else if(p == '-') num.push(a-b);
    else if(p == '*') num.push(a*b);
    else num.push(a/b);
}

int main(){
    unordered_map<char,int> s = {{'+',1},{'-',1},{'*',2},{'/',2}};	///设置运算符优先级
    string str;
    cin>>str;
    for(int i = 0; i < str.size(); i ++){
        char c = str[i];
        if(isdigit(c)){
            int j = i,x = 0;
            while(j < str.size() && isdigit(str[j])){         ///将数字读入完整
                x = x * 10 + str[j++] - '0';				  ///将 “字符数字” 转换为 数字
            }
            num.push(x);
            i = j - 1;                                        ///将i指向最后一个数字
        }else if(c == '('){
            op.push(c);
        }else if(c == ')'){                                   ///碰到右括号将右括号里面的式子计算出来
            while(op.size()&&op.top()!='(') eval();
            op.pop();
        }else{
            while(op.size() && s[op.top()] >= s[c]) eval();	///将运算符栈清空
            op.push(c);
        }
    }
    while(op.size()) eval();
    
    cout<< num.top()<<endl;
    return 0;
    
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值