01-复杂度2 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N​1​​ , N​2​​ , …, N​K​​ }. A continuous subsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

这道题是最大子列和plus
难点在于记录起点与终点的下标。
看代码吧,代码中的注释希望可以给你一些启发

#include<cstdio>
using namespace std;
typedef long long ll;
/* 说几个坑吧
    1.样例中的答案其实是元素,而不是元素下标,由于样例的元素和下标一样,导致我开始wr 仔细审题!
    2.记录答案的Sum初始值最好别设为0,因为当数组全为负数和0时,下标是不会更新的
    3.注意元素下标从一开始很多变量的初始值都不能是0
    3.全是负数时,按题目要求输出
*/
int main()
{
    int n,t;
    int now_s = 1;
    int s = 1,e = 1; //注意不能是0了 应该是1,因为元素下标从1开始
    scanf("%d",&n);
    ll ThisSum = 0,Sum = -100; // 别设为0,
    int * A = new int[n+5];
    int Max = -10;
    for(int i = 1; i<=n; ++i) { //最好从一开始,因为题目中给出的元素下标也是从一开始
        scanf("%d",&A[i]);
        if(Max<A[i])
            Max = A[i];
    }
    if(Max < 0) //注意题目的要求,如果全是负数的情况
        printf("%d %d %d\n",0,A[1],A[n]);
    else {
        for(int i = 1; i<=n; ++i) {
            ThisSum += A[i];
            if(ThisSum < 0) {
                ThisSum = 0;
                now_s = i+1; //这是表示前面的元素都不被采用,那么起始位置应该是下一个点的下标
            } else if(ThisSum > Sum) {
                Sum = ThisSum;
                s = now_s;  //记录下此时子序列和的起点
                e = i;      //它的终点其实就是当前的下标。
            }
        }
        printf("%lld %d %d\n",Sum,A[s],A[e]);
    }
    delete []A;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值