PAT 甲 1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01 02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

注意点:
1、时间和钱的一个运算,我用的方法是,先计算相差的天数,再计算小时和分钟,小时和分钟换算成一共多少分钟,算出价钱相减。
2、结构体排序(发现结构体里套结构体无法用sort,最早用了time结构体,再放入Record,失败了,如果有大佬知道结构体套结构体怎么用sort,请留个言!)
3、如果一个人没有账单最后不打印(感觉这一点是题没有表达清楚)

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string>
#include<algorithm>
using namespace std;

struct Record{
	string name;
	int MM;
	int dd;
	int hh;
	int mm;
	int state;
};

bool compare(Record a,Record b){
	if (a.name!=b.name) return a.name<b.name;
//	if (a.MM!=b.MM) return a.MM<b.mm;
	if (a.dd!=b.dd) return a.dd<b.dd;
	if (a.hh!=b.hh) return a.hh<b.hh;
	if (a.mm!=b.mm) return a.mm<b.mm;
}

int main(){
	string str;	
	Record re[1001],A;
	int pay[26],n,u_num=0,mon,day,hou,min,k;
	for (int i=0;i<24;i++)
		cin>>pay[i];
	cin>>n;
	for (int i=0;i<n;i++){	
		cin>>str;
		re[i].name=str;
		cin>>str;
		re[i].MM=(str[0]-'0')*10+(str[1]-'0');
		re[i].dd=(str[3]-'0')*10+(str[4]-'0');
		re[i].hh=(str[6]-'0')*10+(str[7]-'0');
		re[i].mm=(str[9]-'0')*10+(str[10]-'0');
	
		cin>>str;
		if (str[1]=='n') re[i].state=1;
		else re[i].state=0;
	}
	
	sort(re,re+n,compare);

	int x,y;
	x=y=0;
	while (x<n){
		long count=0;
		for (int i=x;i<n;i++){
			if (re[x].name!=re[i].name) break;
			y=i;
		}
		int f=0,f1=0;
		for (int i=x;i<=y;i++){

			if (re[i].state==1) {
				A=re[i];
				f++;
			}
			if (f>0&&re[i].state==0){
				if (f1==0){
					cout<<re[x].name<<" ";
					printf("%02d\n",re[x].MM); 
				}
				f1++;
				int time;
				long p=0,q=0,g=0,day;
				
				day=0;
				if (re[i].dd>A.dd){
					for (int j=0;j<24;j++)
						day=day+pay[j];
					p+=(re[i].dd-A.dd)*day*60;
				}
				
				q=0;
				for (int j=0;j<re[i].hh;j++)
					q=q+pay[j];
				q=q*60+pay[re[i].hh]*re[i].mm;
					
				g=0;
				for (int j=0;j<A.hh;j++)
					g=g+pay[j];
				g=g*60+pay[A.hh]*A.mm;


				if (re[i].hh>A.hh){	
					p=p+q-g;
				}else {
					p=p-g+q;
				}
				
				time=re[i].dd*24*60+re[i].hh*60+re[i].mm-A.dd*24*60-A.hh*60-A.mm;
				printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.02lf\n",A.dd,A.hh,A.mm,re[i].dd,re[i].hh,re[i].mm,time,p/100.0);
				f=0;
				count+=p;
			}
		}
		x=y+1;
		
		if (f1>0) printf("Total amount: $%.02lf\n",count/100.0);
	}

	return 0;
}

欢迎指导和交流!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值