PAT甲 1040 Longest Symmetric String (25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:
For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

考虑两种情况,aba和aa,因为字符串长度短,暴力求解就可以,比较简单。

#include<iostream>
#include<cstring>
using namespace std;

int main() {
	char str[1001];
	int max=1;
	cin.getline(str, 1001);
	for (int i = 1; i < strlen(str); i++) {
		for (int j = 1; j < strlen(str); j++) {
			if (i - j < 0 || i + j > strlen(str)) break;
			if (str[i - j] == str[i + j]) {
				if (j * 2 + 1 > max) max = j * 2 + 1;
			}
			else break;
		}
	}

	for (int i = 1; i < strlen(str); i++) {
		for (int j = 0; j < strlen(str); j++) {
			if (i-j-1 < 0 || i + j > strlen(str)) break;
			if (str[i - j-1] == str[i + j]) {
				if (j * 2 +2 > max) max = j * 2 + 2;
			}
			else break;
		}
	}

	cout << max;
	return 0;
}

欢迎指导和交流!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值