HDU5019

In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
—Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]

  1. 1 <= T <= 100
  2. 1 <= X, Y, K <= 1 000 000 000 000
    Output
    For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
    Sample Input
    3
    2 3 1
    2 3 2
    8 16 3
    Sample Output
    1
    -1
    2

题意:给你一组数x,y,k让你求出x,y两数中第k大的公约数
思路:比最大公约数小的公约数都是它的因子,所以求出最大公约数的因子从大到小的第k个。
AC代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
using namespace std;
#define ll long long
ll x,y,k;
const int N = 1e5;
ll s[N];
ll gcd(ll a, ll b)
{
    return a%b == 0 ? b : gcd(b, a%b);
}
int main()
{
    int t;
    scanf("%d",&t);

    while(t--)
    {
        memset(s,0,sizeof(s));
        scanf("%lld%lld%lld",&x,&y,&k);
        ll p=gcd(x,y);
        ll n=0;
        for(ll i=1;i*i<=p;i++)
        {
            if(p%i==0)
            {
               s[n++]=i;
               if(i*i!=p)
                s[n++]=p/i;
            }

        }
        if(n<k)
        {
            printf("-1\n");
            continue;
        }
        sort(s,s+n);
            printf("%lld\n",s[n-k]);


    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值