Radar Installation

百练1328:Radar Installation

描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1

分析

贪心算法:
(1)(x,y)->(l,r)改为区间
(2) 按l从小到大排序island
(3)尝试着把radar放在每个island的l处,看是否符合要求(即可覆盖前方未被覆盖的区域)
若符合,则继续向后看;若不符合,则+1,继续向后看

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;

struct Island{
	int x,y;
	double l,r;
	bool operator<(Island& I){
		return l<I.l;
	}
};
int Radar(Island i[],int s,int n,double hou)
{
	if(s>n) return 0;
	double h=hou<i[s].r?hou:i[s].r;
	if(i[s].l<=hou) return Radar(i,s+1,n,h);
	return 1+Radar(i,s+1,n,i[s].r);
}
int main()
{
	int n,d,num=0;
	while(cin>>n>>d)
	{
		if(n==0&&d==0) break;
		++num;
		Island i[n];
		int t=0,an=-1;
		for(int w=0;w<n;w++){
			cin>>i[w].x >>i[w].y;
			if(i[w].y>d){
				t=1;
				continue;
			}
			double dis=sqrt(d*d-i[w].y*i[w].y);
			i[w].l=i[w].x-dis;
			i[w].r=i[w].x+dis;
		} 
		if(t==0)
		{
			sort(i,i+n);
			an=1+Radar(i,1,n-1,i[0].r);	
		}		
		cout<<"Case "<<num<<": "<<an<<endl;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值