java实验---冒泡排序中数据交换的次数

Problem Description

听说过冒泡排序么?一种很暴力的排序方法。今天我们不希望你用它来排序,而是希望你能算出从小到大冒泡排序的过程中一共进行了多少次数据交换。

Input

输入数据的第一行为一个正整数 T ,表示有 T 组测试数据。
接下来T行,每行第一个整数N, 然后有N个整数,无序。0<N <= 100

Output

输出共 T 行。
每行一个整数,代表本行数据从小到大冒泡排序所进行的交换次数。

Sample Input

3
5 1 2 3 4 5
4 5 3 7 1
2 2 1

Sample Output

0
4
1

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner reader = new Scanner(System.in);
		int num = reader.nextInt();
		for(int k = 0; k < num; k++) {
			int n = reader.nextInt();
			int a[] = new int[n];
			for(int i = 0; i < n; i++) {
				a[i] = reader.nextInt();
			}
			int flag, count = 0;
			for(int i = 0; i < n - 1; i++) {
				for(int j = 0; j < n - i - 1; j++){
					if (a[j] > a[j + 1]) {
						flag = a[j];
						a[j] = a[j + 1];
						a[j + 1] = flag;
						count++;
					}
				}
			}
			System.out.println(count);
		}
		
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值