Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:
data left_child right_child
where data
is a string of no more than 10 characters, left_child
and right_child
are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
Figure 1 | Figure 2 |
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:
8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1
Sample Output 1:
(a+b)*(c*(-d))
Sample Input 2:
8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1
Sample Output 2:
(a*2.35)+(-(str%871))
作者: CHEN, Yue
单位: 浙江大学
时间限制: 400 ms
内存限制: 64 MB
代码长度限制: 16 KB
编译器 (31)
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
char data[15];
int l,r;
} tree[25];
int t[25],root;
void In(int v)
{
if(v != -1)
{
if(v != root && (tree[v].l != -1 || tree[v].r != -1))
printf("(");
In(tree[v].l);
printf("%s",tree[v].data);
In(tree[v].r);
if(v != root && (tree[v].l != -1 || tree[v].r != -1))
printf(")");
}
}
int main()
{
int n ;
scanf("%d",&n);
for(int i = 1; i <= n; i++)
{
scanf("%s %d %d",tree[i].data,&tree[i].l, &tree[i].r);
t[tree[i].l] = 1;
t[tree[i].r] = 1;
}
for(int i = 1; i <= n; i++)
{
if(t[i] == 0)
{
root = i ;
break;
}
}
In(root);
return 0;
}